Browse Source
Merge pull request #15033 from neheb/mr
libmraa: fix compilation with GCC10
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
14 additions and
1 deletions
-
libs/libmraa/Makefile
-
libs/libmraa/patches/030-gcc10.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=libmraa |
|
|
|
PKG_VERSION:=2.2.0 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=https://codeload.github.com/eclipse/mraa/tar.gz/v$(PKG_VERSION)? |
|
|
|
|
|
@ -0,0 +1,13 @@ |
|
|
|
--- a/include/version.h
|
|
|
|
+++ b/include/version.h
|
|
|
|
@@ -11,8 +11,8 @@
|
|
|
|
extern "C" { |
|
|
|
#endif |
|
|
|
|
|
|
|
-const char* gVERSION;
|
|
|
|
-const char* gVERSION_SHORT;
|
|
|
|
+extern const char* gVERSION;
|
|
|
|
+extern const char* gVERSION_SHORT;
|
|
|
|
|
|
|
|
#ifdef __cplusplus |
|
|
|
} |