@ -0,0 +1,35 @@ | |||||
--- a/compat.h | |||||
+++ b/compat.h | |||||
@@ -230,7 +230,9 @@ int daemon(int, int); | |||||
#ifndef HAVE_B64_NTOP | |||||
/* b64_ntop.c */ | |||||
#undef b64_ntop /* for Cygwin */ | |||||
-int b64_ntop(const char *, size_t, char *, size_t); | |||||
+int local_b64_ntop(const char *, size_t, char *, size_t); | |||||
+#else | |||||
+#define local_b64_ntop b64_ntop | |||||
#endif | |||||
#ifndef HAVE_FORKPTY | |||||
--- a/tty.c | |||||
+++ b/tty.c | |||||
@@ -1070,7 +1070,7 @@ tty_cmd_setselection(struct tty *tty, co | |||||
off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */ | |||||
buf = xmalloc(off); | |||||
- b64_ntop(ctx->ptr, ctx->num, buf, off); | |||||
+ local_b64_ntop(ctx->ptr, ctx->num, buf, off); | |||||
tty_putcode_ptr2(tty, TTYC_MS, "", buf); | |||||
free(buf); | |||||
--- a/compat/b64_ntop.c | |||||
+++ b/compat/b64_ntop.c | |||||
@@ -122,7 +122,7 @@ static const char Pad64 = '='; | |||||
*/ | |||||
int | |||||
-b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) { | |||||
+local_b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) { | |||||
size_t datalength = 0; | |||||
uint8_t input[3]; | |||||
uint8_t output[4]; |
@ -1,15 +0,0 @@ | |||||
diff --git a/compat.h b/compat.h | |||||
index 65d6ec7..7fc3aa7 100644 | |||||
--- a/compat.h | |||||
+++ b/compat.h | |||||
@@ -219,7 +219,9 @@ int daemon(int, int); | |||||
#ifndef HAVE_B64_NTOP | |||||
/* b64_ntop.c */ | |||||
#undef b64_ntop /* for Cygwin */ | |||||
-int b64_ntop(const char *, size_t, char *, size_t); | |||||
+int local_b64_ntop(const char *, size_t, char *, size_t); | |||||
+#else | |||||
+#define local_b64_ntop b64_ntop | |||||
#endif | |||||
#ifndef HAVE_FORKPTY |
@ -1,13 +0,0 @@ | |||||
diff --git a/compat/b64_ntop.c b/compat/b64_ntop.c | |||||
index 2b4dc2d..a1314ca 100644 | |||||
--- a/compat/b64_ntop.c | |||||
+++ b/compat/b64_ntop.c | |||||
@@ -122,7 +122,7 @@ static const char Pad64 = '='; | |||||
*/ | |||||
int | |||||
-b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) { | |||||
+local_b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) { | |||||
size_t datalength = 0; | |||||
uint8_t input[3]; | |||||
uint8_t output[4]; |
@ -1,13 +0,0 @@ | |||||
diff --git a/tty.c b/tty.c | |||||
index eb2511c..576edbc 100644 | |||||
--- a/tty.c | |||||
+++ b/tty.c | |||||
@@ -1067,7 +1067,7 @@ tty_cmd_setselection(struct tty *tty, const struct tty_ctx *ctx) | |||||
off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */ | |||||
buf = xmalloc(off); | |||||
- b64_ntop(ctx->ptr, ctx->num, buf, off); | |||||
+ local_b64_ntop(ctx->ptr, ctx->num, buf, off); | |||||
tty_putcode_ptr2(tty, TTYC_MS, "", buf); | |||||
free(buf); |
@ -1,14 +0,0 @@ | |||||
--- a/Makefile.in | |||||
+++ b/Makefile.in | |||||
@@ -101,9 +101,9 @@ bin_PROGRAMS = tmux$(EXEEXT) | |||||
@IS_DEBUG_TRUE@@IS_GCC_TRUE@ -Wdeclaration-after-statement | |||||
@IS_DEBUG_TRUE@@IS_GCC_TRUE@am__append_4 = -DDEBUG | |||||
@IS_DEBUG_FALSE@@IS_GCC_TRUE@am__append_5 = -O2 | |||||
-@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote. -I/usr/local/include | |||||
+@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote. | |||||
@IS_DEBUG_TRUE@@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_7 = -Wno-pointer-sign | |||||
-@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I- -I/usr/local/include | |||||
+@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I- | |||||
# Set flags for Solaris. | |||||
@IS_GCC_TRUE@@IS_SUNOS_TRUE@am__append_9 = -D_XPG6 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS |