Browse Source

Boost Makefile Update to Version 1.59

This commit updates Boost to version 1.59, released in the 13th of August of 2015 [1].
  - The new version adds two new template libraries, Convert [2] and CoRoutine2 [3].
  - [Warning]-> CoRoutine2 library absolutly requires a C++14 compiler.
  - patch 001-mips-options-fix.patch was removed, since it is already incorporated upstream.

[1] - http://www.boost.org/users/history/version_1_59_0.html
[2] - http://www.boost.org/libs/convert/
[3] - http://www.boost.org/libs/coroutine2/

Signed-off-by: Carlos Ferreira <carlosmf.pt@gmail.com>
lilik-openwrt-22.03
cmf 9 years ago
parent
commit
ac8ed17be9
2 changed files with 4 additions and 14 deletions
  1. +4
    -3
      libs/boost/Makefile
  2. +0
    -11
      libs/boost/patches/001-mips-options-fix.patch

+ 4
- 3
libs/boost/Makefile View File

@ -16,14 +16,14 @@ include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=boost
PKG_VERSION:=1_58_0
PKG_RELEASE:=6
PKG_VERSION:=1_59_0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/boost
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_VERSION)
PKG_MD5SUM:=5a5d5614d9a07672e1ab2a250b5defc5
PKG_MD5SUM:=51528a0e3b33d9e10aaa311d9eb451e3
PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
@ -109,6 +109,7 @@ define Package/boost-test
$(call Package/boost/Default)
TITLE+= (test)
HIDDEN:=1
DEPENDS+=+boost-system +boost-timer
endef
define Build/Configure


+ 0
- 11
libs/boost/patches/001-mips-options-fix.patch View File

@ -1,11 +0,0 @@
--- boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:01:37.723438995 +0200
+++ boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:00:21.427441384 +0200
@@ -451,7 +451,7 @@
else
{
local arch = [ feature.get-values architecture : $(properties) ] ;
- if $(arch) != arm
+ if $(arch) = power || $(arch) = sparc || $(arch) = x86
{
if $(model) = 32
{

Loading…
Cancel
Save