@ -1,7 +1,7 @@
Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf /src/CMakeLists.txt
Index: sysrepo-7aa2f18d234267403147df92c0005c871f0aa840 /src/CMakeLists.txt
===================================================================
--- sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf .orig/src/CMakeLists.txt
+++ sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf /src/CMakeLists.txt
--- sysrepo-7aa2f18d234267403147df92c0005c871f0aa840 .orig/src/CMakeLists.txt
+++ sysrepo-7aa2f18d234267403147df92c0005c871f0aa840 /src/CMakeLists.txt
@@ -21,14 +21,6 @@ set(GENERATED_PROTO_H "${COMMON_BIN_DIR}
set(GENERATED_PROTO_C "${COMMON_BIN_DIR}/${PROTO_NAME}.pb-c.c")
@ -17,11 +17,11 @@ Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf/src/CMakeLists.txt
configure_file("${COMMON_DIR}/sr_constants.h.in" "${COMMON_BIN_DIR}/sr_constants.h" ESCAPE_QUOTES @ONLY)
Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf /src/common/sysrepo.pb-c.c
Index: sysrepo-7aa2f18d234267403147df92c0005c871f0aa840 /src/common/sysrepo.pb-c.c
===================================================================
--- /dev/null
+++ sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf /src/common/sysrepo.pb-c.c
@@ -0,0 +1,1051 7 @@
+++ sysrepo-7aa2f18d234267403147df92c0005c871f0aa840 /src/common/sysrepo.pb-c.c
@@ -0,0 +1,1053 7 @@
+/* Generated by the protocol buffer compiler. DO NOT EDIT! */
+/* Generated from: sysrepo.proto */
+
@ -6518,9 +6518,29 @@ Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf/src/common/sysrepo.pb-c.
+ (ProtobufCMessageInit) sr__copy_config_req__init,
+ NULL,NULL,NULL /* reserved[123] */
+};
+#define sr__copy_config_resp__field_descriptors NULL
+#define sr__copy_config_resp__field_indices_by_name NULL
+#define sr__copy_config_resp__number_ranges NULL
+static const ProtobufCFieldDescriptor sr__copy_config_resp__field_descriptors[1] =
+{
+ {
+ "errors",
+ 1,
+ PROTOBUF_C_LABEL_REPEATED,
+ PROTOBUF_C_TYPE_MESSAGE,
+ offsetof(Sr__CopyConfigResp, n_errors),
+ offsetof(Sr__CopyConfigResp, errors),
+ &sr__error__descriptor,
+ NULL,
+ 0, /* flags */
+ 0,NULL,NULL /* reserved1,reserved2, etc */
+ },
+};
+static const unsigned sr__copy_config_resp__field_indices_by_name[] = {
+ 0, /* field[0] = errors */
+};
+static const ProtobufCIntRange sr__copy_config_resp__number_ranges[1 + 1] =
+{
+ { 1, 0 },
+ { 0, 1 }
+};
+const ProtobufCMessageDescriptor sr__copy_config_resp__descriptor =
+{
+ PROTOBUF_C__MESSAGE_DESCRIPTOR_MAGIC,
@ -6529,10 +6549,10 @@ Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf/src/common/sysrepo.pb-c.
+ "Sr__CopyConfigResp",
+ "sr",
+ sizeof(Sr__CopyConfigResp),
+ 0 ,
+ 1 ,
+ sr__copy_config_resp__field_descriptors,
+ sr__copy_config_resp__field_indices_by_name,
+ 0 , sr__copy_config_resp__number_ranges,
+ 1 , sr__copy_config_resp__number_ranges,
+ (ProtobufCMessageInit) sr__copy_config_resp__init,
+ NULL,NULL,NULL /* reserved[123] */
+};
@ -10539,11 +10559,11 @@ Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf/src/common/sysrepo.pb-c.
+ sr__operation__value_ranges,
+ NULL,NULL,NULL,NULL /* reserved[1234] */
+};
Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf /src/common/sysrepo.pb-c.h
Index: sysrepo-7aa2f18d234267403147df92c0005c871f0aa840 /src/common/sysrepo.pb-c.h
===================================================================
--- /dev/null
+++ sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf /src/common/sysrepo.pb-c.h
@@ -0,0 +1,4236 @@
+++ sysrepo-7aa2f18d234267403147df92c0005c871f0aa840 /src/common/sysrepo.pb-c.h
@@ -0,0 +1,4238 @@
+/* Generated by the protocol buffer compiler. DO NOT EDIT! */
+/* Generated from: sysrepo.proto */
+
@ -10556,7 +10576,7 @@ Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf/src/common/sysrepo.pb-c.
+
+#if PROTOBUF_C_VERSION_NUMBER < 1000000
+# error This file was generated by a newer version of protoc-c which is incompatible with your libprotobuf-c headers. Please update your headers.
+#elif 1001 001 < PROTOBUF_C_MIN_COMPILER_VERSION
+#elif 1002 001 < PROTOBUF_C_MIN_COMPILER_VERSION
+# error This file was generated by an older version of protoc-c which is incompatible with your libprotobuf-c headers. Please regenerate this file with a newer version of protoc-c.
+#endif
+
@ -11770,10 +11790,12 @@ Index: sysrepo-e4a5705a4c5293ba121048c71899b98243d99edf/src/common/sysrepo.pb-c.
+struct _Sr__CopyConfigResp
+{
+ ProtobufCMessage base;
+ size_t n_errors;
+ Sr__Error **errors;
+};
+#define SR__COPY_CONFIG_RESP__INIT \
+ { PROTOBUF_C_MESSAGE_INIT (&sr__copy_config_resp__descriptor) \
+ }
+ , 0,NULL }
+
+
+/*