Browse Source
Merge pull request #8203 from neheb/libin
libinput: Add missing header to fix compilation
lilik-openwrt-22.03
Hannu Nyman
6 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
11 additions and
1 deletions
-
libs/libinput/Makefile
-
libs/libinput/patches/010-musl-fix.patch
|
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=libinput |
|
|
|
PKG_VERSION:=1.7.3 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz |
|
|
|
PKG_SOURCE_URL:=http://www.freedesktop.org/software/libinput/ |
|
|
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
--- a/src/libinput.h
|
|
|
|
+++ b/src/libinput.h
|
|
|
|
@@ -29,6 +29,7 @@
|
|
|
|
extern "C" { |
|
|
|
#endif |
|
|
|
|
|
|
|
+#include <stdarg.h>
|
|
|
|
#include <stdlib.h> |
|
|
|
#include <stdint.h> |
|
|
|
#include <libudev.h> |