|
|
@ -1,151 +0,0 @@ |
|
|
|
From bab9f2f21b6b27563fe53ae30ba4bf05934ed6f9 Mon Sep 17 00:00:00 2001 |
|
|
|
From: Christian Heimes <christian@python.org> |
|
|
|
Date: Mon, 1 Nov 2021 12:52:04 +0100 |
|
|
|
Subject: [PATCH] bpo-43158: Use configure values for building _uuid extension |
|
|
|
|
|
|
|
Signed-off-by: Christian Heimes <christian@python.org> |
|
|
|
---
|
|
|
|
.../2021-11-01-12-51-46.bpo-43158.fghS6w.rst | 2 + |
|
|
|
configure | 69 +++++++++++++++++++ |
|
|
|
configure.ac | 7 +- |
|
|
|
pyconfig.h.in | 3 + |
|
|
|
setup.py | 12 ++-- |
|
|
|
5 files changed, 86 insertions(+), 7 deletions(-) |
|
|
|
create mode 100644 Misc/NEWS.d/next/Build/2021-11-01-12-51-46.bpo-43158.fghS6w.rst |
|
|
|
|
|
|
|
--- /dev/null
|
|
|
|
+++ b/Misc/NEWS.d/next/Build/2021-11-01-12-51-46.bpo-43158.fghS6w.rst
|
|
|
|
@@ -0,0 +1,2 @@
|
|
|
|
+``setup.py`` now uses values from configure script to build the ``_uuid``
|
|
|
|
+extension module. Configure now detects util-linux's ``libuuid``, too.
|
|
|
|
--- a/configure
|
|
|
|
+++ b/configure
|
|
|
|
@@ -10038,6 +10038,75 @@ $as_echo "no" >&6; }
|
|
|
|
fi |
|
|
|
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext |
|
|
|
|
|
|
|
+save_LIBS=$LIBS
|
|
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing uuid_generate_time_safe" >&5
|
|
|
|
+$as_echo_n "checking for library containing uuid_generate_time_safe... " >&6; }
|
|
|
|
+if ${ac_cv_search_uuid_generate_time_safe+:} false; then :
|
|
|
|
+ $as_echo_n "(cached) " >&6
|
|
|
|
+else
|
|
|
|
+ ac_func_search_save_LIBS=$LIBS
|
|
|
|
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
|
|
+/* end confdefs.h. */
|
|
|
|
+
|
|
|
|
+/* Override any GCC internal prototype to avoid an error.
|
|
|
|
+ Use char because int might match the return type of a GCC
|
|
|
|
+ builtin and then its argument prototype would still apply. */
|
|
|
|
+#ifdef __cplusplus
|
|
|
|
+extern "C"
|
|
|
|
+#endif
|
|
|
|
+char uuid_generate_time_safe ();
|
|
|
|
+int
|
|
|
|
+main ()
|
|
|
|
+{
|
|
|
|
+return uuid_generate_time_safe ();
|
|
|
|
+ ;
|
|
|
|
+ return 0;
|
|
|
|
+}
|
|
|
|
+_ACEOF
|
|
|
|
+for ac_lib in '' uuid; do
|
|
|
|
+ if test -z "$ac_lib"; then
|
|
|
|
+ ac_res="none required"
|
|
|
|
+ else
|
|
|
|
+ ac_res=-l$ac_lib
|
|
|
|
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
|
|
|
+ fi
|
|
|
|
+ if ac_fn_c_try_link "$LINENO"; then :
|
|
|
|
+ ac_cv_search_uuid_generate_time_safe=$ac_res
|
|
|
|
+fi
|
|
|
|
+rm -f core conftest.err conftest.$ac_objext \
|
|
|
|
+ conftest$ac_exeext
|
|
|
|
+ if ${ac_cv_search_uuid_generate_time_safe+:} false; then :
|
|
|
|
+ break
|
|
|
|
+fi
|
|
|
|
+done
|
|
|
|
+if ${ac_cv_search_uuid_generate_time_safe+:} false; then :
|
|
|
|
+
|
|
|
|
+else
|
|
|
|
+ ac_cv_search_uuid_generate_time_safe=no
|
|
|
|
+fi
|
|
|
|
+rm conftest.$ac_ext
|
|
|
|
+LIBS=$ac_func_search_save_LIBS
|
|
|
|
+fi
|
|
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_uuid_generate_time_safe" >&5
|
|
|
|
+$as_echo "$ac_cv_search_uuid_generate_time_safe" >&6; }
|
|
|
|
+ac_res=$ac_cv_search_uuid_generate_time_safe
|
|
|
|
+if test "$ac_res" != no; then :
|
|
|
|
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+$as_echo "#define HAVE_LIBUUID 1" >>confdefs.h
|
|
|
|
+,
|
|
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
|
|
+$as_echo "yes" >&6; }
|
|
|
|
+
|
|
|
|
+else
|
|
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
|
|
+$as_echo "no" >&6; }
|
|
|
|
+
|
|
|
|
+fi
|
|
|
|
+
|
|
|
|
+LIBS=$save_LIBS
|
|
|
|
+
|
|
|
|
# AIX provides support for RFC4122 (uuid) in libc.a starting with AIX 6.1 (anno 2007) |
|
|
|
# FreeBSD and OpenBSD provides support as well |
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for uuid_create" >&5 |
|
|
|
--- a/configure.ac
|
|
|
|
+++ b/configure.ac
|
|
|
|
@@ -2859,8 +2859,13 @@ void *x = uuid_generate_time_safe
|
|
|
|
[AC_MSG_RESULT(no)] |
|
|
|
) |
|
|
|
|
|
|
|
+# check for libuuid from util-linux
|
|
|
|
+save_LIBS=$LIBS
|
|
|
|
+AC_CHECK_LIB([uuid], [uuid_generate_time])
|
|
|
|
+LIBS=$save_LIBS
|
|
|
|
+
|
|
|
|
# AIX provides support for RFC4122 (uuid) in libc.a starting with AIX 6.1 (anno 2007) |
|
|
|
-# FreeBSD and OpenBSD provides support as well
|
|
|
|
+# FreeBSD and OpenBSD provides support in libc as well.
|
|
|
|
AC_MSG_CHECKING(for uuid_create) |
|
|
|
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <uuid.h>]], [[ |
|
|
|
#ifndef uuid_create |
|
|
|
--- a/pyconfig.h.in
|
|
|
|
+++ b/pyconfig.h.in
|
|
|
|
@@ -628,6 +628,9 @@
|
|
|
|
/* Define to 1 if you have the <libutil.h> header file. */ |
|
|
|
#undef HAVE_LIBUTIL_H |
|
|
|
|
|
|
|
+/* Define you have libuuid. */
|
|
|
|
+#undef HAVE_LIBUUID
|
|
|
|
+
|
|
|
|
/* Define if you have the 'link' function. */ |
|
|
|
#undef HAVE_LINK |
|
|
|
|
|
|
|
--- a/setup.py
|
|
|
|
+++ b/setup.py
|
|
|
|
@@ -1850,15 +1850,15 @@ class PyBuildExt(build_ext):
|
|
|
|
|
|
|
|
def detect_uuid(self): |
|
|
|
# Build the _uuid module if possible |
|
|
|
- uuid_incs = find_file("uuid.h", self.inc_dirs, ["/usr/include/uuid"])
|
|
|
|
- if uuid_incs is not None:
|
|
|
|
- if self.compiler.find_library_file(self.lib_dirs, 'uuid'):
|
|
|
|
- uuid_libs = ['uuid']
|
|
|
|
+ uuid_h = sysconfig.get_config_var("HAVE_UUID_H")
|
|
|
|
+ uuid_uuid_h = sysconfig.get_config_var("HAVE_UUID_UUID_H")
|
|
|
|
+ if uuid_h or uuid_uuid_h:
|
|
|
|
+ if sysconfig.get_config_var("HAVE_LIBUUID"):
|
|
|
|
+ uuid_libs = ["uuid"]
|
|
|
|
else: |
|
|
|
uuid_libs = [] |
|
|
|
self.add(Extension('_uuid', ['_uuidmodule.c'], |
|
|
|
- libraries=uuid_libs,
|
|
|
|
- include_dirs=uuid_incs))
|
|
|
|
+ libraries=uuid_libs))
|
|
|
|
else: |
|
|
|
self.missing.append('_uuid') |
|
|
|
|