Browse Source
Merge pull request #7848 from neheb/vno
vpnc: Fix compilation without deprecated OpenSSL 1.0.2 APIs
lilik-openwrt-22.03
Ted Hess
6 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
11 additions and
1 deletions
-
net/vpnc/Makefile
-
net/vpnc/patches/110-openssl-deprecated.patch
|
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
PKG_NAME:=vpnc |
|
|
|
PKG_REV:=550 |
|
|
|
PKG_VERSION:=0.5.3.r$(PKG_REV) |
|
|
|
PKG_RELEASE:=6 |
|
|
|
PKG_RELEASE:=7 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=http://svn.unix-ag.uni-kl.de/vpnc/trunk/ |
|
|
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
--- a/crypto-openssl.c
|
|
|
|
+++ b/crypto-openssl.c
|
|
|
|
@@ -20,6 +20,7 @@
|
|
|
|
#include <string.h> |
|
|
|
#include <errno.h> |
|
|
|
#include <openssl/pem.h> |
|
|
|
+#include <openssl/rsa.h>
|
|
|
|
#include "config.h" |
|
|
|
#include "sysdep.h" |
|
|
|
#include "crypto.h" |