Browse Source

icu: Backport ARMEB support patch

This should fix php compilation on PPC.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
a958f49bd0
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 24 additions and 1 deletions
  1. +1
    -1
      libs/icu/Makefile
  2. +23
    -0
      libs/icu/patches/010-add-big-endian-arm-support.patch

+ 1
- 1
libs/icu/Makefile View File

@ -11,7 +11,7 @@ PKG_NAME:=icu4c
MAJOR_VERSION:=64
MINOR_VERSION:=1
PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)


+ 23
- 0
libs/icu/patches/010-add-big-endian-arm-support.patch View File

@ -0,0 +1,23 @@
From cb5cf996d123014a2420c853c4db60e4500973b1 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Mon, 1 Apr 2019 04:52:32 -0700
Subject: [PATCH] Add big endian ARM support (#92)
This fixes compilation on such platforms.
---
double-conversion/utils.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/source/i18n/double-conversion-utils.h b/source/i18n/double-conversion-utils.h
index 1e44fca..b715c65 100644
--- a/18n/double-conversion-utils.h
+++ b/i18n/double-conversion-utils.h
@@ -99,7 +99,7 @@ int main(int argc, char** argv) {
defined(_POWER) || defined(_ARCH_PPC) || defined(_ARCH_PPC64) || \
defined(__sparc__) || defined(__sparc) || defined(__s390__) || \
defined(__SH4__) || defined(__alpha__) || \
- defined(_MIPS_ARCH_MIPS32R2) || \
+ defined(_MIPS_ARCH_MIPS32R2) || defined(__ARMEB__) || \
defined(__AARCH64EL__) || defined(__aarch64__) || defined(__AARCH64EB__) || \
defined(__riscv) || \
defined(__or1k__) || defined(__arc__) || \

Loading…
Cancel
Save