Browse Source

lttng-ust: Update to 2.10.3

Unlike the current version, this one has support for aarch64. aarch64 is
necessary for several 64-bit targets.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 6 years ago
parent
commit
a944e267b9
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 14 additions and 24 deletions
  1. +12
    -4
      libs/lttng-ust/Makefile
  2. +2
    -2
      libs/lttng-ust/patches/001-no_docs_tests.patch
  3. +0
    -18
      libs/lttng-ust/patches/002-examples.patch

+ 12
- 4
libs/lttng-ust/Makefile View File

@ -8,16 +8,16 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=lttng-ust PKG_NAME:=lttng-ust
PKG_VERSION:=2.6.1
PKG_VERSION:=2.10.3
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/ PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
PKG_HASH:=a75c3ea6cbfa3a89107a2141b27ebabf13964e628855566571f09459bbbc8cb3
PKG_HASH:=9e8420f90d5f963f7aa32bc6d44adc1e491136f687c69ffb7a3075d33b40852b
PKG_MAINTAINER:=
PKG_LICENSE:=LGPL-2.1 GPL-2.0 PKG_LICENSE:=LGPL-2.1 GPL-2.0
PKG_LICENSE_FILES:=COPYING PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
PKG_FIXUP:=autoreconf PKG_FIXUP:=autoreconf
PKG_USE_MIPS16:=0 PKG_USE_MIPS16:=0
@ -34,11 +34,19 @@ define Package/lttng-ust
DEPENDS:= +liburcu +libuuid +librt DEPENDS:= +liburcu +libuuid +librt
endef endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-pic
CONFIGURE_VARS += \
ac_cv_prog_BUILD_GEN_TP_EXAMPLES=no
define Build/InstallDev define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/lttng $(1)/usr/include/ $(CP) $(PKG_INSTALL_DIR)/usr/include/lttng $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ust.pc $(1)/usr/lib/pkgconfig/ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ust.pc $(1)/usr/lib/pkgconfig/
endef endef


+ 2
- 2
libs/lttng-ust/patches/001-no_docs_tests.patch View File

@ -1,7 +1,7 @@
--- a/Makefile.am --- a/Makefile.am
+++ b/Makefile.am +++ b/Makefile.am
@@ -20,8 +20,6 @@ if BUILD_JAVA_AGENT
SUBDIRS += liblttng-ust-java-agent
@@ -26,8 +26,6 @@ SUBDIRS += python-lttngust \
liblttng-ust-python-agent
endif endif
-SUBDIRS += tests doc -SUBDIRS += tests doc


+ 0
- 18
libs/lttng-ust/patches/002-examples.patch View File

@ -1,18 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -350,7 +350,14 @@ AC_ARG_WITH([lttng-system-rundir],
AC_DEFINE_UNQUOTED([LTTNG_SYSTEM_RUNDIR], ["$lttng_system_rundir"],
[LTTng system runtime directory])
-AM_PATH_PYTHON([2.7],BUILD_GEN_TP_EXAMPLES=1,[:])
+AC_ARG_ENABLE([examples],
+ [AS_HELP_STRING([--enable-examples],[build examples [default=no]])],
+ [enable_examples=$enableval],
+ [enable_examples=no]
+)
+if test "x$enable_examples" = "xyes"; then
+ AM_PATH_PYTHON([2.7],BUILD_GEN_TP_EXAMPLES=1,[:])
+fi
AM_CONDITIONAL([BUILD_GEN_TP_EXAMPLES], [test $BUILD_GEN_TP_EXAMPLES], [Build examples requiring lttng-gen-tp])
AC_CONFIG_FILES([

Loading…
Cancel
Save