Browse Source

znc: drop unneeded root check patch

We don't run znc as root anymore, so no need to do the root check after
loading the config.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
lilik-openwrt-22.03
Jonas Gorski 6 years ago
parent
commit
a9051ca918
2 changed files with 1 additions and 53 deletions
  1. +1
    -1
      net/znc/Makefile
  2. +0
    -52
      net/znc/patches/100-move_rootcheck_after_config.patch

+ 1
- 1
net/znc/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=znc
PKG_VERSION:=1.7.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://znc.in/releases \


+ 0
- 52
net/znc/patches/100-move_rootcheck_after_config.patch View File

@ -1,52 +0,0 @@
diff --git a/src/main.cpp b/src/main.cpp
index 6ea10ec..0bf028b 100644
--- a/src/main.cpp
+++ b/src/main.cpp
@@ -422,23 +422,6 @@ int main(int argc, char** argv) {
CUtils::PrintStatus(true, "");
}
- if (isRoot()) {
- CUtils::PrintError(
- "You are running ZNC as root! Don't do that! There are not many "
- "valid");
- CUtils::PrintError(
- "reasons for this and it can, in theory, cause great damage!");
- if (!bAllowRoot) {
- CZNC::DestroyInstance();
- return 1;
- }
- CUtils::PrintError("You have been warned.");
- CUtils::PrintError(
- "Hit CTRL+C now if you don't want to run ZNC as root.");
- CUtils::PrintError("ZNC will start in 30 seconds.");
- sleep(30);
- }
-
if (bMakeConf) {
if (!pZNC->WriteNewConfig(sConfig)) {
CZNC::DestroyInstance();
@@ -460,6 +443,23 @@ int main(int argc, char** argv) {
return 1;
}
+ if (isRoot()) {
+ CUtils::PrintError(
+ "You are running ZNC as root! Don't do that! There are not many "
+ "valid");
+ CUtils::PrintError(
+ "reasons for this and it can, in theory, cause great damage!");
+ if (!bAllowRoot) {
+ CZNC::DestroyInstance();
+ return 1;
+ }
+ CUtils::PrintError("You have been warned.");
+ CUtils::PrintError(
+ "Hit CTRL+C now if you don't want to run ZNC as root.");
+ CUtils::PrintError("ZNC will start in 30 seconds.");
+ sleep(30);
+ }
+
if (bForeground) {
int iPid = getpid();
CUtils::PrintMessage("Staying open for debugging [pid: " +

Loading…
Cancel
Save