gnome-common.m4 and gnome-compiler-flags.m4 were taken from version 3.18.0, and match current master branch. Disable building help and test directories. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>lilik-openwrt-22.03
@ -1,121 +0,0 @@ | |||||
--- a/configure | |||||
+++ b/configure | |||||
@@ -638,8 +638,6 @@ am__EXEEXT_TRUE | |||||
LTLIBOBJS | |||||
LIBOBJS | |||||
YELP_HELP_RULES | |||||
-XMLLINT | |||||
-ITSTOOL | |||||
HELP_DIR | |||||
YELP_LC_DIST | |||||
YELP_LC_MEDIA_LINKS | |||||
@@ -1084,9 +1082,7 @@ MEDIAART_LIBS | |||||
GOM_CFLAGS | |||||
GOM_LIBS | |||||
TRACKER_SPARQL_CFLAGS | |||||
-TRACKER_SPARQL_LIBS | |||||
-ITSTOOL | |||||
-XMLLINT' | |||||
+TRACKER_SPARQL_LIBS' | |||||
# Initialize some variables set by options. | |||||
@@ -1855,8 +1851,6 @@ Some influential environment variables: | |||||
C compiler flags for TRACKER_SPARQL, overriding pkg-config | |||||
TRACKER_SPARQL_LIBS | |||||
linker flags for TRACKER_SPARQL, overriding pkg-config | |||||
- ITSTOOL Path to the `itstool` command | |||||
- XMLLINT Path to the `xmllint` command | |||||
Use these variables to override the choices made by `configure' or to help | |||||
it to find libraries and programs with nonstandard names/locations. | |||||
@@ -16975,89 +16969,6 @@ HELP_DIR="$with_help_dir" | |||||
-# Extract the first word of "itstool", so it can be a program name with args. | |||||
-set dummy itstool; ac_word=$2 | |||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5 | |||||
-$as_echo_n "checking for $ac_word... " >&6; } | |||||
-if ${ac_cv_prog_ITSTOOL+:} false; then : | |||||
- $as_echo_n "(cached) " >&6 | |||||
-else | |||||
- if test -n "$ITSTOOL"; then | |||||
- ac_cv_prog_ITSTOOL="$ITSTOOL" # Let the user override the test. | |||||
-else | |||||
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR | |||||
-for as_dir in $PATH | |||||
-do | |||||
- IFS=$as_save_IFS | |||||
- test -z "$as_dir" && as_dir=. | |||||
- for ac_exec_ext in '' $ac_executable_extensions; do | |||||
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then | |||||
- ac_cv_prog_ITSTOOL="itstool" | |||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5 | |||||
- break 2 | |||||
- fi | |||||
-done | |||||
- done | |||||
-IFS=$as_save_IFS | |||||
- | |||||
-fi | |||||
-fi | |||||
-ITSTOOL=$ac_cv_prog_ITSTOOL | |||||
-if test -n "$ITSTOOL"; then | |||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ITSTOOL" >&5 | |||||
-$as_echo "$ITSTOOL" >&6; } | |||||
-else | |||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5 | |||||
-$as_echo "no" >&6; } | |||||
-fi | |||||
- | |||||
- | |||||
-if test x"$ITSTOOL" = x; then | |||||
- as_fn_error $? "itstool not found" "$LINENO" 5 | |||||
-fi | |||||
- | |||||
- | |||||
-# Extract the first word of "xmllint", so it can be a program name with args. | |||||
-set dummy xmllint; ac_word=$2 | |||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5 | |||||
-$as_echo_n "checking for $ac_word... " >&6; } | |||||
-if ${ac_cv_prog_XMLLINT+:} false; then : | |||||
- $as_echo_n "(cached) " >&6 | |||||
-else | |||||
- if test -n "$XMLLINT"; then | |||||
- ac_cv_prog_XMLLINT="$XMLLINT" # Let the user override the test. | |||||
-else | |||||
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR | |||||
-for as_dir in $PATH | |||||
-do | |||||
- IFS=$as_save_IFS | |||||
- test -z "$as_dir" && as_dir=. | |||||
- for ac_exec_ext in '' $ac_executable_extensions; do | |||||
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then | |||||
- ac_cv_prog_XMLLINT="xmllint" | |||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5 | |||||
- break 2 | |||||
- fi | |||||
-done | |||||
- done | |||||
-IFS=$as_save_IFS | |||||
- | |||||
-fi | |||||
-fi | |||||
-XMLLINT=$ac_cv_prog_XMLLINT | |||||
-if test -n "$XMLLINT"; then | |||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XMLLINT" >&5 | |||||
-$as_echo "$XMLLINT" >&6; } | |||||
-else | |||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5 | |||||
-$as_echo "no" >&6; } | |||||
-fi | |||||
- | |||||
- | |||||
-if test x"$XMLLINT" = x; then | |||||
- as_fn_error $? "xmllint not found" "$LINENO" 5 | |||||
-fi | |||||
- | |||||
YELP_HELP_RULES=' | |||||
HELP_ID ?= | |||||
HELP_POT ?= |
@ -0,0 +1,31 @@ | |||||
--- a/configure.ac | |||||
+++ b/configure.ac | |||||
@@ -1316,7 +1316,7 @@ AC_SUBST(DEPS_OPENSUBTITLES_LIBS) | |||||
# GETTEXT/INTLTOOL | |||||
# ---------------------------------------------------------- | |||||
-IT_PROG_INTLTOOL([0.40.0]) | |||||
+IT_PROG_INTLTOOL([0.40.0], [no-xml]) | |||||
GETTEXT_PACKAGE=grilo-plugins | |||||
AC_SUBST(GETTEXT_PACKAGE) | |||||
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [The domain to use with gettext]) | |||||
@@ -1334,7 +1334,7 @@ AC_SUBST([builddir]) | |||||
# DOCUMENTATION | |||||
# ---------------------------------------------------------- | |||||
-YELP_HELP_INIT | |||||
+#YELP_HELP_INIT | |||||
# ---------------------------------------------------------- | |||||
# OUTPUT | |||||
--- a/Makefile.am | |||||
+++ b/Makefile.am | |||||
@@ -10,7 +10,7 @@ include $(top_srcdir)/release.mk | |||||
ACLOCAL_AMFLAGS = -I m4 | |||||
-SUBDIRS = src help po tests | |||||
+SUBDIRS = src po | |||||
MAINTAINERCLEANFILES = \ | |||||
$(GITIGNORE_MAINTAINERCLEANFILES_TOPLEVEL) \ |
@ -0,0 +1,32 @@ | |||||
# gnome-common.m4 | |||||
# | |||||
# serial 3 | |||||
# | |||||
AU_DEFUN([GNOME_DEBUG_CHECK], | |||||
[ | |||||
AX_CHECK_ENABLE_DEBUG([no],[GNOME_ENABLE_DEBUG]) | |||||
], | |||||
[[$0: This macro is deprecated. You should use AX_CHECK_ENABLE_DEBUG instead and | |||||
replace uses of GNOME_ENABLE_DEBUG with ENABLE_DEBUG. | |||||
See: http://www.gnu.org/software/autoconf-archive/ax_check_enable_debug.html#ax_check_enable_debug]]) | |||||
dnl GNOME_MAINTAINER_MODE_DEFINES () | |||||
dnl define DISABLE_DEPRECATED | |||||
dnl | |||||
AU_DEFUN([GNOME_MAINTAINER_MODE_DEFINES], | |||||
[ | |||||
AC_REQUIRE([AM_MAINTAINER_MODE]) | |||||
DISABLE_DEPRECATED="" | |||||
if test $USE_MAINTAINER_MODE = yes; then | |||||
DOMAINS="GCONF BONOBO BONOBO_UI GNOME LIBGLADE GNOME_VFS WNCK LIBSOUP" | |||||
for DOMAIN in $DOMAINS; do | |||||
DISABLE_DEPRECATED="$DISABLE_DEPRECATED -D${DOMAIN}_DISABLE_DEPRECATED -D${DOMAIN}_DISABLE_SINGLE_INCLUDES" | |||||
done | |||||
fi | |||||
AC_SUBST(DISABLE_DEPRECATED) | |||||
], | |||||
[[$0: This macro is deprecated. All of the modules it disables deprecations for | |||||
are obsolete. Remove it and all uses of DISABLE_DEPRECATED.]]) |
@ -0,0 +1,184 @@ | |||||
# gnome-compiler-flags.m4 | |||||
# | |||||
# serial 4 | |||||
# | |||||
dnl GNOME_COMPILE_WARNINGS | |||||
dnl Turn on many useful compiler warnings and substitute the result into | |||||
dnl WARN_CFLAGS | |||||
dnl For now, only works on GCC | |||||
dnl Pass the default value of the --enable-compile-warnings configure option as | |||||
dnl the first argument to the macro, defaulting to 'yes'. | |||||
dnl Additional warning/error flags can be passed as an optional second argument. | |||||
dnl | |||||
dnl For example: GNOME_COMPILE_WARNINGS([maximum],[-Werror=some-flag -Wfoobar]) | |||||
AU_DEFUN([GNOME_COMPILE_WARNINGS],[ | |||||
dnl ****************************** | |||||
dnl More compiler warnings | |||||
dnl ****************************** | |||||
AC_ARG_ENABLE(compile-warnings, | |||||
AS_HELP_STRING([--enable-compile-warnings=@<:@no/minimum/yes/maximum/error@:>@], | |||||
[Turn on compiler warnings]),, | |||||
[enable_compile_warnings="m4_default([$1],[yes])"]) | |||||
if test "x$GCC" != xyes; then | |||||
enable_compile_warnings=no | |||||
fi | |||||
warning_flags= | |||||
realsave_CFLAGS="$CFLAGS" | |||||
dnl These are warning flags that aren't marked as fatal. Can be | |||||
dnl overridden on a per-project basis with -Wno-foo. | |||||
base_warn_flags=" \ | |||||
-Wall \ | |||||
-Wstrict-prototypes \ | |||||
-Wnested-externs \ | |||||
" | |||||
dnl These compiler flags typically indicate very broken or suspicious | |||||
dnl code. Some of them such as implicit-function-declaration are | |||||
dnl just not default because gcc compiles a lot of legacy code. | |||||
dnl We choose to make this set into explicit errors. | |||||
base_error_flags=" \ | |||||
-Werror=missing-prototypes \ | |||||
-Werror=implicit-function-declaration \ | |||||
-Werror=pointer-arith \ | |||||
-Werror=init-self \ | |||||
-Werror=format-security \ | |||||
-Werror=format=2 \ | |||||
-Werror=missing-include-dirs \ | |||||
-Werror=return-type \ | |||||
" | |||||
dnl Additional warning or error flags provided by the module author to | |||||
dnl allow stricter standards to be imposed on a per-module basis. | |||||
dnl The author can pass -W or -Werror flags here as they see fit. | |||||
additional_flags="m4_default([$2],[])" | |||||
case "$enable_compile_warnings" in | |||||
no) | |||||
warning_flags="-w" | |||||
;; | |||||
minimum) | |||||
warning_flags="-Wall" | |||||
;; | |||||
yes|maximum|error) | |||||
warning_flags="$base_warn_flags $base_error_flags $additional_flags" | |||||
;; | |||||
*) | |||||
AC_MSG_ERROR(Unknown argument '$enable_compile_warnings' to --enable-compile-warnings) | |||||
;; | |||||
esac | |||||
if test "$enable_compile_warnings" = "error" ; then | |||||
warning_flags="$warning_flags -Werror" | |||||
fi | |||||
dnl Check whether GCC supports the warning options | |||||
for option in $warning_flags; do | |||||
save_CFLAGS="$CFLAGS" | |||||
CFLAGS="$CFLAGS $option" | |||||
AC_MSG_CHECKING([whether gcc understands $option]) | |||||
AC_TRY_COMPILE([], [], | |||||
has_option=yes, | |||||
has_option=no,) | |||||
CFLAGS="$save_CFLAGS" | |||||
AC_MSG_RESULT([$has_option]) | |||||
if test $has_option = yes; then | |||||
tested_warning_flags="$tested_warning_flags $option" | |||||
fi | |||||
unset has_option | |||||
unset save_CFLAGS | |||||
done | |||||
unset option | |||||
CFLAGS="$realsave_CFLAGS" | |||||
AC_MSG_CHECKING(what warning flags to pass to the C compiler) | |||||
AC_MSG_RESULT($tested_warning_flags) | |||||
AC_ARG_ENABLE(iso-c, | |||||
AS_HELP_STRING([--enable-iso-c], | |||||
[Try to warn if code is not ISO C ]),, | |||||
[enable_iso_c=no]) | |||||
AC_MSG_CHECKING(what language compliance flags to pass to the C compiler) | |||||
complCFLAGS= | |||||
if test "x$enable_iso_c" != "xno"; then | |||||
if test "x$GCC" = "xyes"; then | |||||
case " $CFLAGS " in | |||||
*[\ \ ]-ansi[\ \ ]*) ;; | |||||
*) complCFLAGS="$complCFLAGS -ansi" ;; | |||||
esac | |||||
case " $CFLAGS " in | |||||
*[\ \ ]-pedantic[\ \ ]*) ;; | |||||
*) complCFLAGS="$complCFLAGS -pedantic" ;; | |||||
esac | |||||
fi | |||||
fi | |||||
AC_MSG_RESULT($complCFLAGS) | |||||
WARN_CFLAGS="$tested_warning_flags $complCFLAGS" | |||||
AC_SUBST(WARN_CFLAGS) | |||||
], | |||||
[[$0: This macro is deprecated. You should use AX_COMPILER_FLAGS instead and | |||||
eliminate use of --enable-iso-c. | |||||
See: http://www.gnu.org/software/autoconf-archive/ax_compiler_flags.html#ax_compiler_flags]]) | |||||
dnl For C++, do basically the same thing. | |||||
AU_DEFUN([GNOME_CXX_WARNINGS],[ | |||||
AC_ARG_ENABLE(cxx-warnings, | |||||
AS_HELP_STRING([--enable-cxx-warnings=@<:@no/minimum/yes@:>@] | |||||
[Turn on compiler warnings.]),, | |||||
[enable_cxx_warnings="m4_default([$1],[minimum])"]) | |||||
AC_MSG_CHECKING(what warning flags to pass to the C++ compiler) | |||||
warnCXXFLAGS= | |||||
if test "x$GXX" != xyes; then | |||||
enable_cxx_warnings=no | |||||
fi | |||||
if test "x$enable_cxx_warnings" != "xno"; then | |||||
if test "x$GXX" = "xyes"; then | |||||
case " $CXXFLAGS " in | |||||
*[\ \ ]-Wall[\ \ ]*) ;; | |||||
*) warnCXXFLAGS="-Wall -Wno-unused" ;; | |||||
esac | |||||
## -W is not all that useful. And it cannot be controlled | |||||
## with individual -Wno-xxx flags, unlike -Wall | |||||
if test "x$enable_cxx_warnings" = "xyes"; then | |||||
warnCXXFLAGS="$warnCXXFLAGS -Wshadow -Woverloaded-virtual" | |||||
fi | |||||
fi | |||||
fi | |||||
AC_MSG_RESULT($warnCXXFLAGS) | |||||
AC_ARG_ENABLE(iso-cxx, | |||||
AS_HELP_STRING([--enable-iso-cxx], | |||||
[Try to warn if code is not ISO C++ ]),, | |||||
[enable_iso_cxx=no]) | |||||
AC_MSG_CHECKING(what language compliance flags to pass to the C++ compiler) | |||||
complCXXFLAGS= | |||||
if test "x$enable_iso_cxx" != "xno"; then | |||||
if test "x$GXX" = "xyes"; then | |||||
case " $CXXFLAGS " in | |||||
*[\ \ ]-ansi[\ \ ]*) ;; | |||||
*) complCXXFLAGS="$complCXXFLAGS -ansi" ;; | |||||
esac | |||||
case " $CXXFLAGS " in | |||||
*[\ \ ]-pedantic[\ \ ]*) ;; | |||||
*) complCXXFLAGS="$complCXXFLAGS -pedantic" ;; | |||||
esac | |||||
fi | |||||
fi | |||||
AC_MSG_RESULT($complCXXFLAGS) | |||||
WARN_CXXFLAGS="$CXXFLAGS $warnCXXFLAGS $complCXXFLAGS" | |||||
AC_SUBST(WARN_CXXFLAGS) | |||||
], | |||||
[[$0: This macro is deprecated. You should use AX_COMPILER_FLAGS instead and | |||||
eliminate use of --enable-iso-cxx. | |||||
See: http://www.gnu.org/software/autoconf-archive/ax_compiler_flags.html#ax_compiler_flags]]) |