Browse Source
libpsl: fix compilation with debian setuptools
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
4 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
12 additions and
1 deletions
-
libs/libpsl/Makefile
-
libs/libpsl/patches/010-python.patch
|
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=libpsl |
|
|
|
PKG_VERSION:=0.21.1 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=https://github.com/rockdaboot/libpsl/releases/download/$(PKG_VERSION) |
|
|
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
--- a/meson.build
|
|
|
|
+++ b/meson.build
|
|
|
|
@@ -131,7 +131,7 @@ if psl_test_file == ''
|
|
|
|
psl_test_file = join_paths(meson.current_source_dir(), 'list', 'tests', 'tests.txt') |
|
|
|
endif |
|
|
|
|
|
|
|
-python = import('python').find_installation()
|
|
|
|
+python = 'python3'
|
|
|
|
pkgconfig = import('pkgconfig') |
|
|
|
|
|
|
|
if cc.get_id() == 'msvc' |