Browse Source

Merge pull request #8495 from ja-pa/mjpg-streamer

mjpg-streamer: update to last upstream version
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
a7e206162c
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
5 changed files with 16 additions and 11 deletions
  1. +3
    -3
      multimedia/mjpg-streamer/Makefile
  2. +1
    -0
      multimedia/mjpg-streamer/files/mjpg-streamer.config
  3. +3
    -0
      multimedia/mjpg-streamer/files/mjpg-streamer.init
  4. +2
    -1
      multimedia/mjpg-streamer/patches/010-optional-plugins-selection.patch
  5. +7
    -7
      multimedia/mjpg-streamer/patches/020-remove-auto-lib-selection.patch

+ 3
- 3
multimedia/mjpg-streamer/Makefile View File

@ -6,17 +6,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mjpg-streamer
PKG_VERSION:=2018-04-14
PKG_VERSION:=2018-10-25
PKG_RELEASE:=1
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>, \
Ted Hess <thess@kitschensync.net>
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/jacksonliam/mjpg-streamer.git
PKG_SOURCE_VERSION:=821c330ea6bbb5fbed98d48e00aac156e923161b
PKG_SOURCE_VERSION:=ddb69b7b4f114f3c2ca01adf55712792ca8aed43
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_MIRROR_HASH:=f95e54bc95c808b9867bbca364e58b6c7e08cb26613205f8d87450ab9c899942
PKG_MIRROR_HASH:=d87ebff5de0c17a35a5b81adad5aa234bc70fe2bb17d1c6277c726845dc043bb
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=LICENSE


+ 1
- 0
multimedia/mjpg-streamer/files/mjpg-streamer.config View File

@ -11,5 +11,6 @@ config mjpg-streamer 'core'
option led 'auto'
option www '/www/webcam'
option port '8080'
#option listen_ip '192.168.1.1'
option username 'openwrt'
option password 'openwrt'

+ 3
- 0
multimedia/mjpg-streamer/files/mjpg-streamer.init View File

@ -69,6 +69,9 @@ start_instance() {
config_get port "$s" 'port'
[ -n "$port" ] && output_arg="${output_arg} --port $port"
config_get listen_ip "$s" 'listen_ip'
[ -n "$listen_ip" ] && output_arg="${output_arg} --listen $listen_ip"
config_get www "$s" 'www'
[ -n "$www" ] && output_arg="${output_arg} --www $www"


+ 2
- 1
multimedia/mjpg-streamer/patches/010-optional-plugins-selection.patch View File

@ -19,6 +19,7 @@
add_subdirectory(plugins/output_udp)
-add_subdirectory(plugins/output_viewer)
+#add_subdirectory(plugins/output_viewer)
add_subdirectory(plugins/output_zmqserver)
#
# mjpg_streamer executable

+ 7
- 7
multimedia/mjpg-streamer/patches/020-remove-auto-lib-selection.patch View File

@ -3,27 +3,27 @@
@@ -49,8 +49,7 @@ set (MJPG_STREAMER_PLUGIN_INSTALL_PATH "
# Global dependencies
#
-find_library(JPEG_LIB jpeg)
-
+#find_library(JPEG_LIB jpeg)
#
# Input plugins
--- a/plugins/input_uvc/CMakeLists.txt
+++ b/plugins/input_uvc/CMakeLists.txt
@@ -8,27 +8,27 @@ if (PLUGIN_INPUT_UVC)
@@ -9,27 +9,27 @@ if (PLUGIN_INPUT_UVC)
add_definitions(-DLINUX -D_GNU_SOURCE)
- find_library(V4L2_LIB v4l2)
+# find_library(V4L2_LIB v4l2)
find_library(V4L2_LIB v4l2)
- find_library(JPEG_LIB jpeg)
+# find_library(JPEG_LIB jpeg)
- if (V4L2_LIB)
- add_definitions(-DUSE_LIBV4L2)
- endif (V4L2_LIB)
+# if (V4L2_LIB)
+# add_definitions(-DUSE_LIBV4L2)
+# add_definitions(-DUSE_LIBV4L2)
+# endif (V4L2_LIB)
- if (NOT JPEG_LIB)


Loading…
Cancel
Save