Browse Source

xtables-addons: update to 3.9

Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
lilik-openwrt-22.03
DENG Qingfang 5 years ago
parent
commit
a6cd4eed98
2 changed files with 6 additions and 15 deletions
  1. +3
    -3
      net/xtables-addons/Makefile
  2. +3
    -12
      net/xtables-addons/patches/002-restore-support-for-Linux-4.14.patch

+ 3
- 3
net/xtables-addons/Makefile View File

@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons PKG_NAME:=xtables-addons
PKG_VERSION:=3.7
PKG_RELEASE:=2
PKG_HASH:=045ee3fcfe5d6edb95483cf49e2446ff8cab4bb79411018b18354138b70c5eb5
PKG_VERSION:=3.9
PKG_RELEASE:=1
PKG_HASH:=064dd68937d98e6cfcbdf51ef459310d9810c17ab31b21285bc7a76cdcef7c49
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/xtables-addons PKG_SOURCE_URL:=@SF/xtables-addons


+ 3
- 12
net/xtables-addons/patches/002-restore-support-for-Linux-4.14.patch View File

@ -6,21 +6,17 @@ This reverts commit bf63a25a64c9223435c26e6543ba749834b47752.
extensions/pknock/xt_pknock.c | 16 ++++++++++++++++ extensions/pknock/xt_pknock.c | 16 ++++++++++++++++
3 files changed, 19 insertions(+), 3 deletions(-) 3 files changed, 19 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 7631f6b..0d3aa72 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -61,7 +61,7 @@ if test -n "$kbuilddir"; then @@ -61,7 +61,7 @@ if test -n "$kbuilddir"; then
echo "WARNING: That kernel version is not officially supported yet. Continue at own luck."; echo "WARNING: That kernel version is not officially supported yet. Continue at own luck.";
elif test "$kmajor" -eq 5 -a "$kminor" -ge 0; then elif test "$kmajor" -eq 5 -a "$kminor" -ge 0; then
: :
- elif test "$kmajor" -eq 4 -a "$kminor" -ge 18; then
- elif test "$kmajor" -eq 4 -a "$kminor" -ge 15; then
+ elif test "$kmajor" -eq 4 -a "$kminor" -ge 14; then + elif test "$kmajor" -eq 4 -a "$kminor" -ge 14; then
: :
else else
echo "WARNING: That kernel version is not officially supported."; echo "WARNING: That kernel version is not officially supported.";
diff --git a/extensions/compat_xtables.h b/extensions/compat_xtables.h
index d08354a..faf5dd8 100644
--- a/extensions/compat_xtables.h --- a/extensions/compat_xtables.h
+++ b/extensions/compat_xtables.h +++ b/extensions/compat_xtables.h
@@ -8,8 +8,8 @@ @@ -8,8 +8,8 @@
@ -34,11 +30,9 @@ index d08354a..faf5dd8 100644
#endif #endif
#if defined(CONFIG_NF_CONNTRACK) || defined(CONFIG_NF_CONNTRACK_MODULE) #if defined(CONFIG_NF_CONNTRACK) || defined(CONFIG_NF_CONNTRACK_MODULE)
diff --git a/extensions/pknock/xt_pknock.c b/extensions/pknock/xt_pknock.c
index c76901a..7be0345 100644
--- a/extensions/pknock/xt_pknock.c --- a/extensions/pknock/xt_pknock.c
+++ b/extensions/pknock/xt_pknock.c +++ b/extensions/pknock/xt_pknock.c
@@ -357,10 +357,18 @@ has_logged_during_this_minute(const struct peer *peer)
@@ -356,10 +356,18 @@ has_logged_during_this_minute(const stru
* *
* @r: rule * @r: rule
*/ */
@ -57,7 +51,7 @@ index c76901a..7be0345 100644
struct peer *peer; struct peer *peer;
struct list_head *pos, *n; struct list_head *pos, *n;
@@ -467,7 +475,15 @@ add_rule(struct xt_pknock_mtinfo *info)
@@ -466,7 +474,15 @@ add_rule(struct xt_pknock_mtinfo *info)
rule->peer_head = alloc_hashtable(peer_hashsize); rule->peer_head = alloc_hashtable(peer_hashsize);
if (rule->peer_head == NULL) if (rule->peer_head == NULL)
goto out; goto out;
@ -73,6 +67,3 @@ index c76901a..7be0345 100644
rule->status_proc = proc_create_data(info->rule_name, 0, pde, rule->status_proc = proc_create_data(info->rule_name, 0, pde,
&pknock_proc_ops, rule); &pknock_proc_ops, rule);
if (rule->status_proc == NULL) if (rule->status_proc == NULL)
--
2.21.0

Loading…
Cancel
Save