Browse Source

python-crypto: let the KeyError bubble up instead of manually throwing an AssertionError

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lilik-openwrt-22.03
Jeffery To 9 years ago
parent
commit
a69543b51e
1 changed files with 7 additions and 9 deletions
  1. +7
    -9
      lang/python-crypto/patches/002-fix-endianness-detect.patch

+ 7
- 9
lang/python-crypto/patches/002-fix-endianness-detect.patch View File

@ -1,15 +1,13 @@
--- a/setup.py 2015-10-30 23:30:22.334127083 +0800
+++ b/setup.py 2015-10-30 23:33:03.856098660 +0800
@@ -100,6 +100,12 @@
--- a/setup.py
+++ b/setup.py
@@ -100,6 +100,10 @@
w(kwd.get("end", "\n")) w(kwd.get("end", "\n"))
def endianness_macro(): def endianness_macro():
+ if "CONFIG_BIG_ENDIAN" in os.environ:
+ if os.environ["CONFIG_BIG_ENDIAN"] == "y":
+ return ('PCT_BIG_ENDIAN', 1)
+ else:
+ return ('PCT_LITTLE_ENDIAN', 1)
+ raise AssertionError("CONFIG_BIG_ENDIAN environment variable missing")
+ if os.environ["CONFIG_BIG_ENDIAN"] == "y":
+ return ('PCT_BIG_ENDIAN', 1)
+ else:
+ return ('PCT_LITTLE_ENDIAN', 1)
s = struct.pack("@I", 0x33221100) s = struct.pack("@I", 0x33221100)
if s == "\x00\x11\x22\x33".encode(): # little endian if s == "\x00\x11\x22\x33".encode(): # little endian
return ('PCT_LITTLE_ENDIAN', 1) return ('PCT_LITTLE_ENDIAN', 1)

Loading…
Cancel
Save