Browse Source

Merge pull request #1484 from jow-/ntripclient-musl-compat

ntripclient: fix musl comaptibility
lilik-openwrt-22.03
Nuno Goncalves 9 years ago
parent
commit
a681ed3daa
2 changed files with 13 additions and 2 deletions
  1. +3
    -2
      net/ntripclient/Makefile
  2. +10
    -0
      net/ntripclient/patches/100-musl-compat.patch

+ 3
- 2
net/ntripclient/Makefile View File

@ -1,6 +1,6 @@
# #
# Copyright (C) 2011 segal.ubi.pt # Copyright (C) 2011 segal.ubi.pt
# Copyright (C) 2010-2014 OpenWrt.org
# Copyright (C) 2010-2015 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ntripclient PKG_NAME:=ntripclient
PKG_VERSION:=1.5.0 PKG_VERSION:=1.5.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_LICENSE:=GPL-2.0+ PKG_LICENSE:=GPL-2.0+
PKG_SOURCE:=$(PKG_NAME).zip PKG_SOURCE:=$(PKG_NAME).zip
@ -36,6 +36,7 @@ endef
define Build/Prepare define Build/Prepare
mkdir -p $(PKG_BUILD_DIR) mkdir -p $(PKG_BUILD_DIR)
unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR) unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR)
$(call Build/Prepare/Default)
endef endef
MAKE_FLAGS += \ MAKE_FLAGS += \


+ 10
- 0
net/ntripclient/patches/100-musl-compat.patch View File

@ -0,0 +1,10 @@
--- a/ntripclient.c
+++ b/ntripclient.c
@@ -44,6 +44,7 @@
#include <fcntl.h>
#include <unistd.h>
#include <arpa/inet.h>
+ #include <sys/select.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <netdb.h>

Loading…
Cancel
Save