Browse Source

Merge pull request #6919 from neheb/tdb

tdb: Remove libbsd dependency
lilik-openwrt-22.03
Ted Hess 6 years ago
committed by GitHub
parent
commit
a603a9a26a
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 62 additions and 1 deletions
  1. +1
    -1
      libs/tdb/Makefile
  2. +61
    -0
      libs/tdb/patches/100-Remove_libbsd_dependency_check.patch

+ 1
- 1
libs/tdb/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tdb
PKG_VERSION:=1.3.16
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz


+ 61
- 0
libs/tdb/patches/100-Remove_libbsd_dependency_check.patch View File

@ -0,0 +1,61 @@
diff --git a/lib/replace/wscript b/lib/replace/wscript
index fd00a42..337d559 100644
--- a/lib/replace/wscript
+++ b/lib/replace/wscript
@@ -340,22 +340,13 @@ def configure(conf):
conf.CHECK_FUNCS('prctl dirname basename')
- strlcpy_in_bsd = False
-
- # libbsd on some platforms provides strlcpy and strlcat
- if not conf.CHECK_FUNCS('strlcpy strlcat'):
- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
- checklibc=True):
- strlcpy_in_bsd = True
- if not conf.CHECK_FUNCS('getpeereid'):
- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
- conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
- if not conf.CHECK_FUNCS('setproctitle_init'):
- conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h')
-
- if not conf.CHECK_FUNCS('closefrom'):
- conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
+ # Not checking for libbsd
+ conf.CHECK_FUNCS('strlcpy strlcat')
+ conf.CHECK_FUNCS('getpeereid')
+ conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h')
+ conf.CHECK_FUNCS('setproctitle_init')
+
+ conf.CHECK_FUNCS('closefrom')
conf.CHECK_CODE('''
struct ucred cred;
@@ -698,9 +689,6 @@ def configure(conf):
# look for a method of finding the list of network interfaces
for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
- bsd_for_strlcpy = ''
- if strlcpy_in_bsd:
- bsd_for_strlcpy = ' bsd'
if conf.CHECK_CODE('''
#define %s 1
#define NO_CONFIG_H 1
@@ -713,7 +701,7 @@ def configure(conf):
#include "test/getifaddrs.c"
''' % method,
method,
- lib='nsl socket' + bsd_for_strlcpy,
+ lib='nsl socket',
addmain=False,
execute=True):
break
@@ -761,7 +749,6 @@ def build(bld):
break
extra_libs = ''
- if bld.CONFIG_SET('HAVE_LIBBSD'): extra_libs += ' bsd'
bld.SAMBA_SUBSYSTEM('LIBREPLACE_HOSTCC',
REPLACE_HOSTCC_SOURCE,

Loading…
Cancel
Save