Browse Source

Merge pull request #16520 from ClaymorePT/boost_1.77.0

boost: Bump to version 1.77.0
lilik-openwrt-22.03
Rosen Penev 3 years ago
committed by GitHub
parent
commit
a28d632e78
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
4 changed files with 6 additions and 46 deletions
  1. +6
    -6
      libs/boost/Makefile
  2. +0
    -11
      libs/boost/patches/010-mips64-fiber.patch
  3. +0
    -0
      libs/boost/patches/010-sparc.patch
  4. +0
    -29
      libs/boost/patches/020-regex.patch

+ 6
- 6
libs/boost/Makefile View File

@ -11,13 +11,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=boost
PKG_VERSION:=1.76.0
PKG_SOURCE_VERSION:=1_76_0
PKG_VERSION:=1.77.0
PKG_SOURCE_VERSION:=1_77_0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
PKG_HASH:=f0397ba6e982c4450f27bf32a2a83292aba035b827a5623a14636ea583318c41
PKG_HASH:=fc9f85fc030e233142908241af7a846e60630aa7388de9a5fafb1f3a26840854
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
PKG_LICENSE:=BSL-1.0
@ -42,7 +42,7 @@ define Package/boost/Default
endef
define Package/boost/description
This package provides the Boost v1.76.0 libraries.
This package provides the Boost v1.77.0 libraries.
Boost is a set of free, peer-reviewed, portable C++ source libraries.
This package provides the following run-time libraries:
@ -77,7 +77,7 @@ This package provides the following run-time libraries:
- wave
There are many more header-only libraries supported by Boost.
See more at http://www.boost.org/doc/libs/1_76_0/
See more at http://www.boost.org/doc/libs/1_77_0/
endef
PKG_BUILD_DEPENDS:=boost/host
@ -342,7 +342,7 @@ $(eval $(call DefineBoostLibrary,coroutine,system chrono context thread,,!boost-
$(eval $(call DefineBoostLibrary,date_time))
#$(eval $(call DefineBoostLibrary,exception,,))
$(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclude))
$(eval $(call DefineBoostLibrary,filesystem,system))
$(eval $(call DefineBoostLibrary,filesystem,system atomic))
$(eval $(call DefineBoostLibrary,graph,regex))
$(eval $(call DefineBoostLibrary,iostreams,,,,zlib liblzma libbz2 libzstd))
$(eval $(call DefineBoostLibrary,json,container))


+ 0
- 11
libs/boost/patches/010-mips64-fiber.patch View File

@ -1,11 +0,0 @@
--- a/boost/fiber/detail/cpu_relax.hpp
+++ b/boost/fiber/detail/cpu_relax.hpp
@@ -47,7 +47,7 @@ namespace detail {
# else
# define cpu_relax() asm volatile ("nop" ::: "memory");
# endif
-#elif BOOST_ARCH_MIPS && (__mips_isa_rev > 1) && !defined(_MIPS_ARCH_OCTEONP)
+#elif BOOST_ARCH_MIPS && (((__mips_isa_rev > 1) && defined(__mips32)) || ((__mips_isa_rev > 2) && defined(__mips64)))
# define cpu_relax() asm volatile ("pause" ::: "memory");
#elif BOOST_ARCH_PPC
// http://code.metager.de/source/xref/gnu/glibc/sysdeps/powerpc/sys/platform/ppc.h

libs/boost/patches/030-sparc.patch → libs/boost/patches/010-sparc.patch View File


+ 0
- 29
libs/boost/patches/020-regex.patch View File

@ -1,29 +0,0 @@
--- a/boost/regex/v5/mem_block_cache.hpp
+++ b/boost/regex/v5/mem_block_cache.hpp
@@ -85,10 +85,10 @@ struct mem_block_node
struct mem_block_cache
{
// this member has to be statically initialsed:
- mem_block_node* next;
- unsigned cached_blocks;
+ mem_block_node* next { nullptr };
+ unsigned cached_blocks { 0 };
#ifdef BOOST_HAS_THREADS
- boost::static_mutex mut;
+ std::mutex mut;
#endif
~mem_block_cache()
@@ -133,11 +133,7 @@ struct mem_block_cache
}
static mem_block_cache& instance()
{
-#ifdef BOOST_HAS_THREADS
- static mem_block_cache block_cache = { 0, 0, BOOST_STATIC_MUTEX_INIT, };
-#else
- static mem_block_cache block_cache = { 0, 0, };
-#endif
+ static mem_block_cache block_cache;
return block_cache;
}
};

Loading…
Cancel
Save