Browse Source

ibrdtnd: Switch to uClibc++

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
a216030b59
2 changed files with 22 additions and 1 deletions
  1. +2
    -1
      net/ibrdtnd/Makefile
  2. +20
    -0
      net/ibrdtnd/patches/030-openssl-deprecated.patch

+ 2
- 1
net/ibrdtnd/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ibrdtnd
PKG_VERSION:=1.0.1
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
@ -20,6 +20,7 @@ PKG_LICENSE:=Apache-2.0
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/ibrdtnd


+ 20
- 0
net/ibrdtnd/patches/030-openssl-deprecated.patch View File

@ -0,0 +1,20 @@
--- a/src/security/SecurityKeyManager.cpp
+++ b/src/security/SecurityKeyManager.cpp
@@ -29,6 +29,7 @@
#include <fstream>
#include <fcntl.h>
+#include <openssl/bn.h>
#include <openssl/pem.h>
#include <openssl/rsa.h>
#include <openssl/err.h>
--- a/src/security/exchange/DHProtocol.cpp
+++ b/src/security/exchange/DHProtocol.cpp
@@ -28,6 +28,7 @@
#include <ibrcommon/ssl/HMacStream.h>
#include <ibrcommon/Logger.h>
+#include <openssl/dh.h>
#include <openssl/rand.h>
#include <openssl/pem.h>
#include "openssl_compat.h"

Loading…
Cancel
Save