Browse Source

madplay: remove OSS variant

with the latest version, there's no OSS support. At least --without-oss
does not work.

Remove autoconf patches and add gettext-version fixup.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
a1a10cf373
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 6 additions and 71 deletions
  1. +6
    -28
      sound/madplay/Makefile
  2. +0
    -30
      sound/madplay/patches/010-use_correct_shell.patch
  3. +0
    -13
      sound/madplay/patches/020-no-po.patch

+ 6
- 28
sound/madplay/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=madplay
PKG_VERSION:=0.15.2b
PKG_RELEASE:=8
PKG_RELEASE:=9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/mad \
@ -20,25 +20,20 @@ PKG_MAINTAINER:=Simon Peter <probono@puredarwin.org>
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
define Package/madplay/default
define Package/madplay
SECTION:=sound
CATEGORY:=Sound
DEPENDS:=+libid3tag +libmad $(INTL_DEPENDS) $(2)
TITLE:=MPEG audio player in fixed point - $(1)
VARIANT:=$(1)
URL:=http://sourceforge.net/projects/mad
DEPENDS:=+libid3tag +libmad $(INTL_DEPENDS) +alsa-lib
TITLE:=MPEG audio player in fixed point - ALSA
URL:=https://sourceforge.net/projects/mad
endef
Package/madplay-alsa=$(call Package/madplay/default,alsa,+alsa-lib)
Package/madplay=$(call Package/madplay/default,oss)
define Package/madplay/description
MAD is an MPEG audio decoder. It currently only supports the MPEG 1
standard, but fully implements all three audio layers (Layer I, Layer II,
@ -52,34 +47,17 @@ CONFIGURE_ARGS += \
--disable-debugging \
--disable-profiling \
--disable-experimental \
--without-libiconv-prefix \
--without-libintl-prefix \
--without-esd \
--with-alsa
CONFIGURE_VARS += \
lt_prog_compiler_pic=$(FPIC)
MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
ifeq ($(BUILD_VARIANT),alsa)
CONFIGURE_ARGS += \
--without-oss \
--with-alsa
else
CONFIGURE_ARGS += \
--without-alsa \
--with-oss
endif
define Package/madplay/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
endef
define Package/madplay-alsa/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
endef
$(eval $(call BuildPackage,madplay-alsa))
$(eval $(call BuildPackage,madplay))

+ 0
- 30
sound/madplay/patches/010-use_correct_shell.patch View File

@ -1,30 +0,0 @@
--- a/intl/Makefile.in
+++ b/intl/Makefile.in
@@ -19,7 +19,7 @@
PACKAGE = @PACKAGE@
VERSION = @VERSION@
-SHELL = /bin/sh
+SHELL = @SHELL@
srcdir = @srcdir@
top_srcdir = @top_srcdir@
@@ -56,6 +56,7 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" -DLO
-DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"$(libdir)\" -DNO_XMALLOC \
-Dset_relocation_prefix=libintl_set_relocation_prefix \
-Drelocate=libintl_relocate \
+-DINSTALLPREFIX=\"$(prefix)\" \
-DDEPENDS_ON_LIBICONV=1 @DEFS@
CPPFLAGS = @CPPFLAGS@
CFLAGS = @CFLAGS@
--- a/po/Makefile.in.in
+++ b/po/Makefile.in.in
@@ -13,7 +13,7 @@
PACKAGE = @PACKAGE@
VERSION = @VERSION@
-SHELL = /bin/sh
+SHELL = @SHELL@
@SET_MAKE@
srcdir = @srcdir@

+ 0
- 13
sound/madplay/patches/020-no-po.patch View File

@ -1,13 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,8 +24,8 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = intl po
-DIST_SUBDIRS = intl po m4 msvc++
+SUBDIRS = intl
+DIST_SUBDIRS = intl m4 msvc++
ACLOCAL_AMFLAGS = -I m4

Loading…
Cancel
Save