Browse Source

git: update to 2.6.3

Signed-off-by: Luka Perkov <luka@openwrt.org>
lilik-openwrt-22.03
Luka Perkov 9 years ago
parent
commit
a150eb16f3
4 changed files with 27 additions and 26 deletions
  1. +4
    -3
      net/git/Makefile
  2. +18
    -18
      net/git/patches/100-convert_builtin.patch
  3. +3
    -3
      net/git/patches/300-configure_for_crosscompiling
  4. +2
    -2
      net/git/patches/400-imapsend_without_curl.patch

+ 4
- 3
net/git/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=git PKG_NAME:=git
PKG_VERSION:=2.6.0
PKG_VERSION:=2.6.3
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/scm/git/ PKG_SOURCE_URL:=@KERNEL/software/scm/git/
PKG_MD5SUM:=6b7d43d615fb3f0dfecf4d131e23f438
PKG_MD5SUM:=5a6375349c3f13c8dbbabfc327bae429
PKG_INSTALL:=1 PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
@ -83,7 +83,7 @@ endef
define Package/git/install define Package/git/install
$(INSTALL_DIR) $(1)/usr/bin $(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/git $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/git $(1)/usr/bin
$(RM) $(PKG_INSTALL_DIR)/usr/bin/git-cvsserver $(RM) $(PKG_INSTALL_DIR)/usr/bin/git-cvsserver
$(CP) $(PKG_INSTALL_DIR)/usr/bin/git-* $(1)/usr/bin $(CP) $(PKG_INSTALL_DIR)/usr/bin/git-* $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib/git-core $(INSTALL_DIR) $(1)/usr/lib/git-core
@ -98,6 +98,7 @@ define Package/git/install
-cf - \ -cf - \
usr/lib/git-core \ usr/lib/git-core \
) | ( cd $(1); $(TAR) -xf - ) ) | ( cd $(1); $(TAR) -xf - )
$(INSTALL_DIR) $(1)/usr/share/git-core/templates
endef endef
define Package/git-http/install define Package/git-http/install


+ 18
- 18
net/git/patches/100-convert_builtin.patch View File

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -549,16 +549,7 @@ EXTRA_PROGRAMS =
@@ -557,16 +557,7 @@ EXTRA_PROGRAMS =
# ... and all the rest that could be moved out of bindir to gitexecdir # ... and all the rest that could be moved out of bindir to gitexecdir
PROGRAMS += $(EXTRA_PROGRAMS) PROGRAMS += $(EXTRA_PROGRAMS)
@ -17,9 +17,9 @@
# Binary suffix, set to .exe for Windows builds # Binary suffix, set to .exe for Windows builds
X = X =
@@ -907,6 +898,11 @@ BUILTIN_OBJS += builtin/verify-commit.o
BUILTIN_OBJS += builtin/verify-pack.o
@@ -923,6 +914,11 @@ BUILTIN_OBJS += builtin/verify-pack.o
BUILTIN_OBJS += builtin/verify-tag.o BUILTIN_OBJS += builtin/verify-tag.o
BUILTIN_OBJS += builtin/worktree.o
BUILTIN_OBJS += builtin/write-tree.o BUILTIN_OBJS += builtin/write-tree.o
+BUILTIN_OBJS += builtin/daemon.o +BUILTIN_OBJS += builtin/daemon.o
+BUILTIN_OBJS += builtin/fast-import.o +BUILTIN_OBJS += builtin/fast-import.o
@ -29,7 +29,7 @@
GITLIBS = $(LIB_FILE) $(XDIFF_LIB) GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
EXTLIBS = EXTLIBS =
@@ -1089,7 +1085,7 @@ endif
@@ -1106,7 +1102,7 @@ endif
EXTLIBS += -lz EXTLIBS += -lz
ifndef NO_OPENSSL ifndef NO_OPENSSL
@ -38,7 +38,7 @@
ifdef OPENSSLDIR ifdef OPENSSLDIR
BASIC_CFLAGS += -I$(OPENSSLDIR)/include BASIC_CFLAGS += -I$(OPENSSLDIR)/include
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib) OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
@@ -1956,10 +1952,6 @@ endif
@@ -1977,10 +1973,6 @@ endif
git-%$X: %.o GIT-LDFLAGS $(GITLIBS) git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS) $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
@ -48,8 +48,8 @@
- -
git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS) git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \ $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
$(LIBS) $(CURL_LIBCURL)
@@ -2279,10 +2271,11 @@ endif
$(CURL_LIBCURL) $(LIBS)
@@ -2300,10 +2292,11 @@ endif
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \ bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \ execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
{ test "$$bindir/" = "$$execdir/" || \ { test "$$bindir/" = "$$execdir/" || \
@ -64,7 +64,7 @@
} && \ } && \
--- a/builtin.h --- a/builtin.h
+++ b/builtin.h +++ b/builtin.h
@@ -138,5 +138,10 @@ extern int cmd_verify_pack(int argc, con
@@ -141,5 +141,10 @@ extern int cmd_verify_pack(int argc, con
extern int cmd_show_ref(int argc, const char **argv, const char *prefix); extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
extern int cmd_pack_refs(int argc, const char **argv, const char *prefix); extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
extern int cmd_replace(int argc, const char **argv, const char *prefix); extern int cmd_replace(int argc, const char **argv, const char *prefix);
@ -97,7 +97,7 @@
+#include "../upload-pack.c" +#include "../upload-pack.c"
--- a/daemon.c --- a/daemon.c
+++ b/daemon.c +++ b/daemon.c
@@ -1192,7 +1192,7 @@ static int serve(struct string_list *lis
@@ -1184,7 +1184,7 @@ static int serve(struct string_list *lis
return service_loop(&socklist); return service_loop(&socklist);
} }
@ -106,8 +106,8 @@
{ {
int listen_port = 0; int listen_port = 0;
struct string_list listen_addr = STRING_LIST_INIT_NODUP; struct string_list listen_addr = STRING_LIST_INIT_NODUP;
@@ -1388,12 +1388,13 @@ int main(int argc, char **argv)
store_pid(pid_file);
@@ -1380,12 +1380,13 @@ int main(int argc, char **argv)
write_file(pid_file, "%"PRIuMAX, (uintmax_t) getpid());
/* prepare argv for serving-processes */ /* prepare argv for serving-processes */
- cld_argv = xmalloc(sizeof (char *) * (argc + 2)); - cld_argv = xmalloc(sizeof (char *) * (argc + 2));
@ -127,7 +127,7 @@
} }
--- a/fast-import.c --- a/fast-import.c
+++ b/fast-import.c +++ b/fast-import.c
@@ -3351,7 +3351,7 @@ static void parse_argv(void)
@@ -3380,7 +3380,7 @@ static void parse_argv(void)
read_marks(); read_marks();
} }
@ -152,7 +152,7 @@
{ {
int status, help; int status, help;
struct stat st; struct stat st;
@@ -395,6 +395,7 @@ static struct cmd_struct commands[] = {
@@ -396,6 +396,7 @@ static struct cmd_struct commands[] = {
{ "config", cmd_config, RUN_SETUP_GENTLY }, { "config", cmd_config, RUN_SETUP_GENTLY },
{ "count-objects", cmd_count_objects, RUN_SETUP }, { "count-objects", cmd_count_objects, RUN_SETUP },
{ "credential", cmd_credential, RUN_SETUP_GENTLY }, { "credential", cmd_credential, RUN_SETUP_GENTLY },
@ -160,7 +160,7 @@
{ "describe", cmd_describe, RUN_SETUP }, { "describe", cmd_describe, RUN_SETUP },
{ "diff", cmd_diff }, { "diff", cmd_diff },
{ "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE }, { "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE },
@@ -413,6 +414,7 @@ static struct cmd_struct commands[] = {
@@ -414,6 +415,7 @@ static struct cmd_struct commands[] = {
{ "grep", cmd_grep, RUN_SETUP_GENTLY }, { "grep", cmd_grep, RUN_SETUP_GENTLY },
{ "hash-object", cmd_hash_object }, { "hash-object", cmd_hash_object },
{ "help", cmd_help }, { "help", cmd_help },
@ -168,7 +168,7 @@
{ "index-pack", cmd_index_pack, RUN_SETUP_GENTLY }, { "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
{ "init", cmd_init_db, NO_SETUP }, { "init", cmd_init_db, NO_SETUP },
{ "init-db", cmd_init_db, NO_SETUP }, { "init-db", cmd_init_db, NO_SETUP },
@@ -461,6 +463,7 @@ static struct cmd_struct commands[] = {
@@ -463,6 +465,7 @@ static struct cmd_struct commands[] = {
{ "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE }, { "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
{ "rm", cmd_rm, RUN_SETUP }, { "rm", cmd_rm, RUN_SETUP },
{ "send-pack", cmd_send_pack, RUN_SETUP }, { "send-pack", cmd_send_pack, RUN_SETUP },
@ -176,7 +176,7 @@
{ "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER }, { "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
{ "show", cmd_show, RUN_SETUP }, { "show", cmd_show, RUN_SETUP },
{ "show-branch", cmd_show_branch, RUN_SETUP }, { "show-branch", cmd_show_branch, RUN_SETUP },
@@ -477,6 +480,7 @@ static struct cmd_struct commands[] = {
@@ -479,6 +482,7 @@ static struct cmd_struct commands[] = {
{ "update-server-info", cmd_update_server_info, RUN_SETUP }, { "update-server-info", cmd_update_server_info, RUN_SETUP },
{ "upload-archive", cmd_upload_archive }, { "upload-archive", cmd_upload_archive },
{ "upload-archive--writer", cmd_upload_archive_writer }, { "upload-archive--writer", cmd_upload_archive_writer },
@ -186,7 +186,7 @@
{ "verify-pack", cmd_verify_pack }, { "verify-pack", cmd_verify_pack },
--- a/imap-send.c --- a/imap-send.c
+++ b/imap-send.c +++ b/imap-send.c
@@ -1492,7 +1492,7 @@ static int curl_append_msgs_to_imap(stru
@@ -1496,7 +1496,7 @@ static int curl_append_msgs_to_imap(stru
} }
#endif #endif
@ -208,7 +208,7 @@
const char **user_argv; const char **user_argv;
--- a/upload-pack.c --- a/upload-pack.c
+++ b/upload-pack.c +++ b/upload-pack.c
@@ -797,7 +797,7 @@ static int upload_pack_config(const char
@@ -819,7 +819,7 @@ static int upload_pack_config(const char
return parse_hide_refs_config(var, value, "uploadpack"); return parse_hide_refs_config(var, value, "uploadpack");
} }


+ 3
- 3
net/git/patches/300-configure_for_crosscompiling View File

@ -1,6 +1,6 @@
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -844,7 +844,8 @@ AC_RUN_IFELSE(
@@ -867,7 +867,8 @@ AC_RUN_IFELSE(
FILE *f = fopen(".", "r"); FILE *f = fopen(".", "r");
return f && fread(&c, 1, 1, f)]])], return f && fread(&c, 1, 1, f)]])],
[ac_cv_fread_reads_directories=no], [ac_cv_fread_reads_directories=no],
@ -10,7 +10,7 @@
]) ])
if test $ac_cv_fread_reads_directories = yes; then if test $ac_cv_fread_reads_directories = yes; then
FREAD_READS_DIRECTORIES=UnfortunatelyYes FREAD_READS_DIRECTORIES=UnfortunatelyYes
@@ -878,7 +879,8 @@ AC_RUN_IFELSE(
@@ -901,7 +902,8 @@ AC_RUN_IFELSE(
if (snprintf(buf, 3, "%s", "12345") != 5 if (snprintf(buf, 3, "%s", "12345") != 5
|| strcmp(buf, "12")) return 1]])], || strcmp(buf, "12")) return 1]])],
[ac_cv_snprintf_returns_bogus=no], [ac_cv_snprintf_returns_bogus=no],
@ -20,7 +20,7 @@
]) ])
if test $ac_cv_snprintf_returns_bogus = yes; then if test $ac_cv_snprintf_returns_bogus = yes; then
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
@@ -901,7 +903,8 @@ yippeeyeswehaveit
@@ -924,7 +926,8 @@ yippeeyeswehaveit
#endif #endif
]), ]),
[ac_cv_sane_mode_bits=yes], [ac_cv_sane_mode_bits=yes],


+ 2
- 2
net/git/patches/400-imapsend_without_curl.patch View File

@ -1,8 +1,8 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -1058,7 +1058,7 @@ else
@@ -1074,7 +1074,7 @@ else
endif endif
curl_check := $(shell (echo 072200; curl-config --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
ifeq "$(curl_check)" "072200" ifeq "$(curl_check)" "072200"
- USE_CURL_FOR_IMAP_SEND = YesPlease - USE_CURL_FOR_IMAP_SEND = YesPlease
+# USE_CURL_FOR_IMAP_SEND = YesPlease +# USE_CURL_FOR_IMAP_SEND = YesPlease


Loading…
Cancel
Save