Browse Source

open-plc-utils: update to commit 6a07d62158

This fixes an alignment issue on some platforms, which renders
some tools, e.g. plcID, unusable.

While at, switch to xz compression for the tarball, drop an already
mainlined patch and remove a meanswhile absolete compiler switch.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lilik-openwrt-22.03
Michael Heimpold 8 years ago
parent
commit
a0d4b804b1
2 changed files with 3 additions and 40 deletions
  1. +3
    -7
      utils/open-plc-utils/Makefile
  2. +0
    -33
      utils/open-plc-utils/patches/100-musl-compat.patch

+ 3
- 7
utils/open-plc-utils/Makefile View File

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=open-plc-utils PKG_NAME:=open-plc-utils
PKG_VERSION:=2015-09-21
PKG_VERSION:=2017-01-11
PKG_RELEASE:=$(PKG_SOURCE_VERSION) PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=885a1b7e2e663b5ab8797db6d40a0318131fdf18
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_SOURCE_VERSION:=6a07d621583cb86ddf2fddcacb41cc4cf28bf33a
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org> PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org>
@ -75,10 +75,6 @@ OPEN_PLC_UTILS_APPS:=efbu efeu efru efsu edru edsu nics \
$(foreach a,$(OPEN_PLC_UTILS_APPS),$(eval $(call GenPlugin,$(a)))) $(foreach a,$(OPEN_PLC_UTILS_APPS),$(eval $(call GenPlugin,$(a))))
ifdef CONFIG_USE_MUSL
TARGET_CFLAGS += -D__UCLIBC__
endif
define Build/Compile define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE) -C $(PKG_BUILD_DIR) \
EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \ EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \


+ 0
- 33
utils/open-plc-utils/patches/100-musl-compat.patch View File

@ -1,33 +0,0 @@
--- a/ether/readpacket.c
+++ b/ether/readpacket.c
@@ -70,6 +70,10 @@
#include <memory.h>
#include <errno.h>
+#if defined (__linux__)
+#include <poll.h>
+#endif
+
#include "../ether/channel.h"
#include "../tools/memory.h"
#include "../tools/error.h"
@@ -95,8 +99,6 @@ ssize_t readpacket (struct channel const
#elif defined (__linux__)
-#include <sys/poll.h>
-
struct pollfd pollfd =
{
channel->fd,
--- a/serial/serial.c
+++ b/serial/serial.c
@@ -69,6 +69,8 @@
#if defined (WIN32)
#include <Windows.h>
+#else
+#include <sys/select.h>
#endif
/*====================================================================*

Loading…
Cancel
Save