Browse Source

alsa-lib: update to 1.1.3

Signed-off-by: Peter Wagner <tripolar@gmx.at>
lilik-openwrt-22.03
Peter Wagner 8 years ago
parent
commit
a0c957d73c
3 changed files with 58 additions and 20 deletions
  1. +2
    -2
      libs/alsa-lib/Makefile
  2. +12
    -0
      libs/alsa-lib/patches/002-compile_fix.patch
  3. +44
    -18
      libs/alsa-lib/patches/005-fix_include_file_redirect_warnings.patch

+ 2
- 2
libs/alsa-lib/Makefile View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-lib
PKG_VERSION:=1.1.0
PKG_VERSION:=1.1.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
http://alsa.cybermirror.org/lib/
PKG_MD5SUM:=69515ca73c3c4a212ef45160dea846c1
PKG_HASH:=71282502184c592c1a008e256c22ed0ba5728ca65e05273ceb480c70f515969c
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
Peter Wagner <tripolar@gmx.at>


+ 12
- 0
libs/alsa-lib/patches/002-compile_fix.patch View File

@ -0,0 +1,12 @@
diff --git a/src/ucm/parser.c b/src/ucm/parser.c
index c98373a..f520abc 100644
--- a/src/ucm/parser.c
+++ b/src/ucm/parser.c
@@ -32,6 +32,7 @@
#include "ucm_local.h"
#include <dirent.h>
+#include <limits.h>
/** The name of the environment variable containing the UCM directory */
#define ALSA_CONFIG_UCM_VAR "ALSA_CONFIG_UCM"

+ 44
- 18
libs/alsa-lib/patches/005-fix_include_file_redirect_warnings.patch View File

@ -1,14 +1,5 @@
--- a/src/seq/seq.c
+++ b/src/seq/seq.c
@@ -777,7 +777,7 @@ void event_filter(snd_seq_t *seq, snd_se
*/
-#include <sys/poll.h>
+#include <poll.h>
#include "seq_local.h"
/****************************************************************************
diff --git a/aserver/aserver.c b/aserver/aserver.c
index ac20706..46f731a 100644
--- a/aserver/aserver.c
+++ b/aserver/aserver.c
@@ -20,7 +20,7 @@
@ -20,6 +11,8 @@
#include <sys/un.h>
#include <sys/uio.h>
#include <stdio.h>
diff --git a/include/asoundlib-head.h b/include/asoundlib-head.h
index 1ec611e..21e32c6 100644
--- a/include/asoundlib-head.h
+++ b/include/asoundlib-head.h
@@ -35,6 +35,6 @@
@ -30,6 +23,8 @@
+#include <poll.h>
#include <errno.h>
#include <stdarg.h>
diff --git a/include/asoundlib.h b/include/asoundlib.h
index 3c2766e..a546194 100644
--- a/include/asoundlib.h
+++ b/include/asoundlib.h
@@ -35,7 +35,7 @@
@ -41,6 +36,8 @@
#include <errno.h>
#include <stdarg.h>
#include <endian.h>
diff --git a/include/local.h b/include/local.h
index 317f2e3..6a43a47 100644
--- a/include/local.h
+++ b/include/local.h
@@ -47,7 +47,7 @@
@ -51,18 +48,22 @@
+#include <poll.h>
#include <sys/types.h>
#include <errno.h>
#include <linux/types.h>
#if defined(__linux__)
diff --git a/src/control/control.c b/src/control/control.c
index 134ba4c..6439b29 100644
--- a/src/control/control.c
+++ b/src/control/control.c
@@ -48,7 +48,7 @@ and IEC958 structure.
@@ -90,7 +90,7 @@ against the original design.
#include <string.h>
#include <fcntl.h>
#include <signal.h>
-#include <sys/poll.h>
+#include <poll.h>
#include <stdbool.h>
#include "control_local.h"
/**
diff --git a/src/control/control_shm.c b/src/control/control_shm.c
index bd07d4a..9a2e268 100644
--- a/src/control/control_shm.c
+++ b/src/control/control_shm.c
@@ -27,7 +27,7 @@
@ -74,9 +75,11 @@
#include <sys/un.h>
#include <sys/uio.h>
#include <sys/mman.h>
diff --git a/src/pcm/pcm.c b/src/pcm/pcm.c
index 0cf740f..a28589d 100644
--- a/src/pcm/pcm.c
+++ b/src/pcm/pcm.c
@@ -634,7 +634,7 @@ playback devices.
@@ -651,7 +651,7 @@ playback devices.
#include <stdarg.h>
#include <signal.h>
#include <ctype.h>
@ -85,6 +88,8 @@
#include <sys/mman.h>
#include <limits.h>
#include "pcm_local.h"
diff --git a/src/pcm/pcm_direct.c b/src/pcm/pcm_direct.c
index 6434983..b3c0b2d 100644
--- a/src/pcm/pcm_direct.c
+++ b/src/pcm/pcm_direct.c
@@ -30,7 +30,7 @@
@ -96,17 +101,21 @@
#include <sys/shm.h>
#include <sys/sem.h>
#include <sys/wait.h>
diff --git a/src/pcm/pcm_mmap.c b/src/pcm/pcm_mmap.c
index 1948289..4cf220a 100644
--- a/src/pcm/pcm_mmap.c
+++ b/src/pcm/pcm_mmap.c
@@ -21,7 +21,7 @@
@@ -22,7 +22,7 @@
#include <stdio.h>
#include <malloc.h>
#include <string.h>
-#include <sys/poll.h>
+#include <poll.h>
#include <sys/mman.h>
#ifdef HAVE_SYS_SHM_H
#include <sys/shm.h>
#include "pcm_local.h"
diff --git a/src/pcm/pcm_share.c b/src/pcm/pcm_share.c
index 5d8aaf2..21a57fc 100644
--- a/src/pcm/pcm_share.c
+++ b/src/pcm/pcm_share.c
@@ -34,7 +34,7 @@
@ -118,6 +127,8 @@
#include <pthread.h>
#include "pcm_local.h"
diff --git a/src/pcm/pcm_shm.c b/src/pcm/pcm_shm.c
index a815ac6..4ee958c 100644
--- a/src/pcm/pcm_shm.c
+++ b/src/pcm/pcm_shm.c
@@ -36,7 +36,7 @@
@ -129,9 +140,24 @@
#include <sys/un.h>
#include <sys/mman.h>
#include <netinet/in.h>
diff --git a/src/seq/seq.c b/src/seq/seq.c
index 9279830..d2027cb 100644
--- a/src/seq/seq.c
+++ b/src/seq/seq.c
@@ -777,7 +777,7 @@ void event_filter(snd_seq_t *seq, snd_seq_event_t *ev)
*/
-#include <sys/poll.h>
+#include <poll.h>
#include "seq_local.h"
/****************************************************************************
diff --git a/src/shmarea.c b/src/shmarea.c
index 9843aa8..eaa71f0 100644
--- a/src/shmarea.c
+++ b/src/shmarea.c
@@ -22,7 +22,7 @@
@@ -27,7 +27,7 @@
#include <malloc.h>
#include <string.h>
#include <errno.h>


Loading…
Cancel
Save