Browse Source

libupnp: update to 1.12.0

Remove outdated build options.

Fix CPE ID.

Add PKG_BUILD_PARALLEL for faster compilation.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
a06584aaa5
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 9 additions and 33 deletions
  1. +9
    -9
      libs/libupnp/Makefile
  2. +0
    -24
      libs/libupnp/patches/100-fix-pthread-detach.patch

+ 9
- 9
libs/libupnp/Makefile View File

@ -1,18 +1,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libupnp
PKG_VERSION:=1.8.4
PKG_RELEASE:=2
PKG_VERSION:=1.12.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/pupnp
PKG_HASH:=188d3f786d92fe14191f17634d2d87847eee7d2b568a5257ea23262fec9973d6
PKG_HASH:=1bda3939976a9a2901382233db39379ce993b59a0e7fd0dd781212a44a9b44a2
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_CPE_ID:=cpe:/a:portable_sdk_for_upnp_project:portable_sdk_for_upnp
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:libupnp_project:libupnp
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@ -46,11 +48,9 @@ define Package/libupnp-sample/description
TVcontrolpoint & tvdevice sample applications run inside /etc/upnp-tvdevice/
endef
TARGET_CFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -flto
TARGET_CFLAGS += -flto
TARGET_LDFLAGS += -flto
CONFIGURE_VARS += ac_cv_lib_compat_ftime=no
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/upnp $(1)/usr/include/


+ 0
- 24
libs/libupnp/patches/100-fix-pthread-detach.patch View File

@ -1,24 +0,0 @@
From 386b7ed79146ecf7a3bba49f48cb8f41a9b49170 Mon Sep 17 00:00:00 2001
From: Jean-Francois Dockes <jf@dockes.org>
Date: Sun, 27 Jan 2019 10:44:17 +0100
Subject: [PATCH] Do not try to detach detached thread, the result is
undefined. Fixes issue #102
---
upnp/src/threadutil/ThreadPool.c | 5 -----
1 file changed, 5 deletions(-)
--- a/upnp/src/threadutil/ThreadPool.c
+++ b/upnp/src/threadutil/ThreadPool.c
@@ -651,11 +651,6 @@ static int CreateWorker(
rc = ithread_create(&temp, &attr, WorkerThread, tp);
ithread_attr_destroy(&attr);
if (rc == 0) {
- rc = ithread_detach(temp);
- /* ithread_detach will return EINVAL if thread has been
- successfully detached by ithread_create */
- if (rc == EINVAL)
- rc = 0;
tp->pendingWorkerThreadStart = 1;
/* wait until the new worker thread starts */
while (tp->pendingWorkerThreadStart) {

Loading…
Cancel
Save