Browse Source

frr: update to 8.2

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
lilik-openwrt-22.03
Lucian Cristian 2 years ago
committed by Rosen Penev
parent
commit
9ffd55a993
5 changed files with 21 additions and 11 deletions
  1. +5
    -5
      net/frr/Makefile
  2. +1
    -1
      net/frr/patches/098-fix_mips_libyang.patch
  3. +10
    -0
      net/frr/patches/997-reverse_python_test.patch
  4. +1
    -1
      net/frr/patches/998-mips64_fix.patch
  5. +4
    -4
      net/frr/patches/999-thread_reverse.patch

+ 5
- 5
net/frr/Makefile View File

@ -7,16 +7,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=frr
PKG_VERSION:=8.1.0
PKG_RELEASE:=3
PKG_SOURCE_DATE:=2022-02-11
PKG_VERSION:=8.2.0
PKG_RELEASE:=1
PKG_SOURCE_DATE:=2022-03-05
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
PKG_SOURCE_VERSION:=1794094a65b904ae3a10c51f021c3b7800a9b116
PKG_SOURCE_VERSION:=47a5de9c038c17038cef61786fd1216d33ee0f66
PKG_SOURCE_URL:=https://codeload.github.com/FRRouting/frr/tar.gz/$(PKG_SOURCE_VERSION)?
PKG_HASH:=3cbf39efdce7b07ab1fb0991db7e201d7ae810f04f79a7f173f64d90a441948b
PKG_HASH:=6007ae2fdb2e068696f92dd000f247ef2a27d846863b0b1552752e41ed5f4017
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION)


+ 1
- 1
net/frr/patches/098-fix_mips_libyang.patch View File

@ -1,6 +1,6 @@
--- a/lib/northbound.h
+++ b/lib/northbound.h
@@ -592,11 +592,7 @@ struct frr_yang_module_info {
@@ -593,11 +593,7 @@ struct frr_yang_module_info {
/* Priority - lower priorities are processed first. */
uint32_t priority;


+ 10
- 0
net/frr/patches/997-reverse_python_test.patch View File

@ -0,0 +1,10 @@
--- a/configure.ac
+++ b/configure.ac
@@ -816,7 +816,6 @@ fi
#
AS_IF([test "$host" = "$build"], [
- AM_PATH_PYTHON([3])
AC_CHECK_HEADER([gelf.h], [], [
AC_MSG_ERROR([libelf headers are required for building clippy. (Host only when cross-compiling.)])
])

+ 1
- 1
net/frr/patches/998-mips64_fix.patch View File

@ -1,6 +1,6 @@
--- a/lib/xref.h
+++ b/lib/xref.h
@@ -122,7 +122,7 @@ extern struct xref_block *xref_blocks;
@@ -135,7 +135,7 @@ extern struct xref_block *xref_blocks;
extern void xref_block_add(struct xref_block *block);
extern void xref_gcc_workaround(const struct xref *xref);


+ 4
- 4
net/frr/patches/999-thread_reverse.patch View File

@ -1,6 +1,6 @@
--- a/lib/thread.c
+++ b/lib/thread.c
@@ -824,13 +824,9 @@ static void thread_free(struct thread_ma
@@ -830,13 +830,9 @@ static void thread_free(struct thread_ma
XFREE(MTYPE_THREAD, thread);
}
@ -16,7 +16,7 @@
/*
* If timer_wait is null here, that means poll() should block
* indefinitely, unless the thread_master has overridden it by setting
@@ -861,58 +857,15 @@ static int fd_poll(struct thread_master
@@ -867,58 +863,15 @@ static int fd_poll(struct thread_master
rcu_assert_read_unlocked();
/* add poll pipe poker */
@ -82,7 +82,7 @@
while (read(m->io_pipe[0], &trash, sizeof(trash)) > 0)
;
@@ -1700,7 +1653,7 @@ struct thread *thread_fetch(struct threa
@@ -1718,7 +1671,7 @@ struct thread *thread_fetch(struct threa
struct timeval zerotime = {0, 0};
struct timeval tv;
struct timeval *tw = NULL;
@ -91,7 +91,7 @@
int num = 0;
do {
@@ -1776,14 +1729,14 @@ struct thread *thread_fetch(struct threa
@@ -1794,14 +1747,14 @@ struct thread *thread_fetch(struct threa
pthread_mutex_unlock(&m->mtx);
{


Loading…
Cancel
Save