Browse Source

nginx: fix detection of gcc builtin atomic operations

Needed by stream module

Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
lilik-openwrt-22.03
Deng Qingfang 6 years ago
parent
commit
9ef3498e91
2 changed files with 10 additions and 1 deletions
  1. +1
    -1
      net/nginx/Makefile
  2. +9
    -0
      net/nginx/patches/101-feature_test_fix.patch

+ 1
- 1
net/nginx/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.15.6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nginx.org/download/


+ 9
- 0
net/nginx/patches/101-feature_test_fix.patch View File

@ -11,6 +11,15 @@
ngx_feature_libs=
--- a/auto/cc/conf
+++ b/auto/cc/conf
@@ -183,7 +183,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
else
ngx_feature="gcc builtin atomic operations"
ngx_feature_name=NGX_HAVE_GCC_ATOMIC
- ngx_feature_run=yes
+ ngx_feature_run=no
ngx_feature_incs=
ngx_feature_path=
ngx_feature_libs=
@@ -204,7 +204,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
else
ngx_feature="C99 variadic macros"


Loading…
Cancel
Save