Browse Source

Merge pull request #2527 from commodo/ovs-kernel-patch-fix

openvswitch: fix kernel 4.4 patch for pre-4.4 kernels
lilik-openwrt-22.03
Hannu Nyman 8 years ago
parent
commit
9ea127d524
2 changed files with 2 additions and 2 deletions
  1. +1
    -1
      net/openvswitch/Makefile
  2. +1
    -1
      net/openvswitch/patches/0011-kernel-4-4-support.patch

+ 1
- 1
net/openvswitch/Makefile View File

@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=openvswitch
PKG_RELEASE:=6
PKG_RELEASE:=7
PKG_VERSION:=2.5.0
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_LICENSE:=Apache-2.0


+ 1
- 1
net/openvswitch/patches/0011-kernel-4-4-support.patch View File

@ -129,8 +129,8 @@ index cd87bcc..b749301 100644
unsigned int mtu = ip_skb_dst_mtu(skb);
struct iphdr *iph = ip_hdr(skb);
struct rtable *rt = skb_rtable(skb);
+ NET_DECLARE_INIT(net, dev_net(dev));
struct net_device *dev = rt->dst.dev;
+ NET_DECLARE_INIT(net, dev_net(dev));
if (unlikely(((iph->frag_off & htons(IP_DF)) && !skb->ignore_df) ||
@@ -102,7 +115,7 @@ static inline int rpl_ip_do_fragment(struct sock *sk, struct sk_buff *skb,


Loading…
Cancel
Save