Browse Source

libvpx: force to use gcc as linker

libvpx excepts gcc to be used as linker. However, it respects
what is defined in LD. The problem is that LD is defined by
OpenWRT as *-ld.

Forcing the LD env for configure and make solves the problem.
Also, the patch that modified ld call to match what *-ld provides
is not needed anymore.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
lilik-openwrt-22.03
Luiz Angelo Daros de Luca 10 years ago
parent
commit
9e673f2a4b
2 changed files with 7 additions and 15 deletions
  1. +7
    -3
      libs/libvpx/Makefile
  2. +0
    -12
      libs/libvpx/patches/001-remove_Wl.patch

+ 7
- 3
libs/libvpx/Makefile View File

@ -23,7 +23,6 @@ PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
#PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@ -55,9 +54,14 @@ ifneq ($(findstring -Os,$(TARGET_CFLAGS)),)
CONFIGURE_ARGS += --enable-small
endif
# libvpx expects gcc as linker but uses $LD if provided
# However, OpenWRT defines LD as *-uclibc-ld and not *-gcc
CONFIGURE_VARS += \
CROSS=$(GNU_TARGET_NAME)\
extralibs="-lc -lgcc_s"
CROSS=$(GNU_TARGET_NAME) \
LD="$(TARGET_CC)" \
MAKE_FLAGS += \
LD="$(TARGET_CC)" \
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/vpx/


+ 0
- 12
libs/libvpx/patches/001-remove_Wl.patch View File

@ -1,12 +0,0 @@
--- libvpx-1.3.0/build/make/Makefile.old 2014-12-06 02:17:06.648714353 -0200
+++ libvpx-1.3.0/build/make/Makefile 2014-12-06 02:17:16.096555499 -0200
@@ -268,8 +268,8 @@
$(1):
$(if $(quiet),@echo " [LD] $$@")
$(qexec)$$(LD) -shared $$(LDFLAGS) \
- -Wl,--no-undefined -Wl,-soname,$$(SONAME) \
- -Wl,--version-script,$$(EXPORTS_FILE) -o $$@ \
+ --no-undefined -soname $$(SONAME) \
+ --version-script $$(EXPORTS_FILE) -o $$@ \
$$(filter %.o,$$^) $$(extralibs)
endef

Loading…
Cancel
Save