Browse Source

v4l-utils: add libudev-zero dependency

When libudev-zero is enabled, v4l-utils links against it, and the
package build fails due to a missing dependency:

Package v4l-utils is missing dependencies for the following libraries:
libudev.so.1

As disabling udev doesn't seem to be supported in v4l-utils, simply add
the dependency to fix the build.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
lilik-openwrt-22.03
Stijn Tintel 3 years ago
parent
commit
9dc0fd7c14
2 changed files with 1 additions and 23 deletions
  1. +1
    -1
      libs/libv4l/Makefile
  2. +0
    -22
      libs/libv4l/patches/010-remove-libudev-check.patch

+ 1
- 1
libs/libv4l/Makefile View File

@ -64,7 +64,7 @@ define Package/v4l-utils
SECTION:=utils
CATEGORY:=Utilities
TITLE+= utilities
DEPENDS:= +libv4l +libstdcpp $(ICONV_DEPENDS) $(INTL_DEPENDS)
DEPENDS:= +libudev-zero +libv4l +libstdcpp $(ICONV_DEPENDS) $(INTL_DEPENDS)
LICENSE:=GPL-2.0-or-later
LICENSE_FILES:=COPYING
endef


+ 0
- 22
libs/libv4l/patches/010-remove-libudev-check.patch View File

@ -1,22 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -291,16 +291,9 @@ else
AC_MSG_WARN(ALSA library not available)
fi
-PKG_CHECK_MODULES(libudev, libudev, have_libudev=yes, have_libudev=no)
-if test "x$have_libudev" = "xyes"; then
- AC_DEFINE([HAVE_LIBUDEV], [], [Use libudev])
- LIBUDEV_CFLAGS="$libudev_CFLAGS"
- LIBUDEV_LIBS="$libudev_LIBS"
- AC_SUBST(LIBUDEV_CFLAGS)
- AC_SUBST(LIBUDEV_LIBS)
-else
- AC_MSG_WARN(udev library not available)
-fi
+
+# Force building without udev
+have_libudev=no
AC_SUBST([JPEG_LIBS])

Loading…
Cancel
Save