Browse Source

Merge pull request #1492 from tru7/linknx

linknx: fix musl compatibility
lilik-openwrt-22.03
Jo-Philipp Wich 9 years ago
parent
commit
9d423ba553
3 changed files with 23 additions and 1 deletions
  1. +2
    -1
      net/linknx/Makefile
  2. +10
    -0
      net/linknx/patches/010-musl-compat
  3. +11
    -0
      net/linknx/patches/012-fix-linknx.cpp

+ 2
- 1
net/linknx/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linknx
PKG_VERSION:=0.0.1.32
PKG_RELEASE:=6
PKG_RELEASE:=7
PKG_MD5SUM:=7ecc1208f59bceb05068c752b2250b63
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
@ -18,6 +18,7 @@ PKG_LICENSE:=GPL-2.0+
PKG_SOURCE_URL:=@SF/linknx
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DEPENDS:=argp-standalone
PKG_FORTIFY_SOURCE:=1
include $(INCLUDE_DIR)/package.mk


+ 10
- 0
net/linknx/patches/010-musl-compat View File

@ -0,0 +1,10 @@
--- a/src/eibclient.c 2007-10-11 01:55:31.000000000 +0200
+++ b/src/eibclient.c 2015-06-27 22:18:01.433296921 +0200
@@ -32,6 +32,7 @@
#include <netinet/in.h>
#include <netdb.h>
#include <errno.h>
+#include <string.h>
#include "config.h"

+ 11
- 0
net/linknx/patches/012-fix-linknx.cpp View File

@ -0,0 +1,11 @@
--- a/src/linknx.cpp 2012-06-04 22:12:13.000000000 +0200
+++ b/src/linknx.cpp 2015-06-27 22:35:23.705721355 +0200
@@ -136,7 +136,7 @@
if (errno)
printf (": %s\n", strerror (errno));
else
- printf ("\n", strerror (errno));
+ printf ("\n");
exit (1);
}

Loading…
Cancel
Save