Browse Source

ola: Update to 0.9.7.

Signed-off-by: Christian Beier <cb@shoutrlabs.com>
lilik-openwrt-22.03
Christian Beier 9 years ago
parent
commit
9c418e5445
2 changed files with 17 additions and 2 deletions
  1. +2
    -2
      net/ola/Makefile
  2. +15
    -0
      net/ola/patches/001-include-endian_h.patch

+ 2
- 2
net/ola/Makefile View File

@ -9,13 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ola
PKG_VERSION:=0.9.6
PKG_VERSION:=0.9.7
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/OpenLightingProject/ola.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=e9ece0540fb40beb1be33417cb7e0abf45af74e0
PKG_SOURCE_VERSION:=2a306e4f0221fea9f4833ba04b042e72c6f10cd3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_LICENSE:=LGPL-2.1+


+ 15
- 0
net/ola/patches/001-include-endian_h.patch View File

@ -0,0 +1,15 @@
diff --git a/common/network/NetworkUtils.cpp b/common/network/NetworkUtils.cpp
index 3914818..094a311 100644
--- a/common/network/NetworkUtils.cpp
+++ b/common/network/NetworkUtils.cpp
@@ -39,6 +39,10 @@ typedef uint32_t in_addr_t;
#include <resolv.h>
#endif
+#ifdef HAVE_ENDIAN_H
+#include <endian.h>
+#endif
+
#if defined(HAVE_LINUX_NETLINK_H) && defined(HAVE_LINUX_RTNETLINK_H)
#define USE_NETLINK_FOR_DEFAULT_ROUTE 1
#include <linux/netlink.h>

Loading…
Cancel
Save