Browse Source

openssh: update to 7.5p1, remove unneeded patches

Signed-off-by: Peter Wagner <tripolar@gmx.at>
lilik-openwrt-22.03
Peter Wagner 7 years ago
parent
commit
9be7653a3a
4 changed files with 7 additions and 103 deletions
  1. +5
    -5
      net/openssh/Makefile
  2. +2
    -2
      net/openssh/patches/100-dscp-qos.patch
  3. +0
    -12
      net/openssh/patches/130-implicit_memset_decl_fix.patch
  4. +0
    -84
      net/openssh/patches/140-pam_uclibc_pthreads_fix.patch

+ 5
- 5
net/openssh/Makefile View File

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
PKG_VERSION:=7.4p1
PKG_VERSION:=7.5p1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.spline.de/pub/OpenBSD/OpenSSH/portable/ \
https://anorien.csc.warwick.ac.uk/pub/OpenBSD/OpenSSH/portable/ \
https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/
PKG_MD5SUM:=b2db2a83caf66a208bb78d6d287cdaa3
PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
https://ftp.spline.de/pub/OpenBSD/OpenSSH/portable/ \
https://anorien.csc.warwick.ac.uk/pub/OpenBSD/OpenSSH/portable/
PKG_HASH:=9846e3c5fab9f0547400b4d2c017992f914222b3fd1f8eee6c7dc6bc5e59f9f0
PKG_LICENSE:=BSD ISC
PKG_LICENSE_FILES:=LICENCE


net/openssh/patches/200-dscp-qos.patch → net/openssh/patches/100-dscp-qos.patch View File


+ 0
- 12
net/openssh/patches/130-implicit_memset_decl_fix.patch View File

@ -1,12 +0,0 @@
--- a/includes.h
+++ b/includes.h
@@ -60,6 +60,9 @@
/*
*-*-nto-qnx needs these headers for strcasecmp and LASTLOG_FILE respectively
*/
+#ifdef HAVE_STRING_H
+# include <string.h>
+#endif
#ifdef HAVE_STRINGS_H
# include <strings.h>
#endif

+ 0
- 84
net/openssh/patches/140-pam_uclibc_pthreads_fix.patch View File

@ -1,84 +0,0 @@
--- a/auth-pam.c
+++ b/auth-pam.c
@@ -159,7 +159,7 @@ sshpam_sigchld_handler(int sig)
}
if (WIFSIGNALED(sshpam_thread_status) &&
WTERMSIG(sshpam_thread_status) == SIGTERM)
- return; /* terminated by pthread_cancel */
+ return; /* terminated by pthread2_cancel */
if (!WIFEXITED(sshpam_thread_status))
sigdie("PAM: authentication thread exited unexpectedly");
if (WEXITSTATUS(sshpam_thread_status) != 0)
@@ -168,14 +168,14 @@ sshpam_sigchld_handler(int sig)
/* ARGSUSED */
static void
-pthread_exit(void *value)
+pthread2_exit(void *value)
{
_exit(0);
}
/* ARGSUSED */
static int
-pthread_create(sp_pthread_t *thread, const void *attr,
+pthread2_create(sp_pthread_t *thread, const void *attr,
void *(*thread_start)(void *), void *arg)
{
pid_t pid;
@@ -201,7 +201,7 @@ pthread_create(sp_pthread_t *thread, con
}
static int
-pthread_cancel(sp_pthread_t thread)
+pthread2_cancel(sp_pthread_t thread)
{
signal(SIGCHLD, sshpam_oldsig);
return (kill(thread, SIGTERM));
@@ -209,7 +209,7 @@ pthread_cancel(sp_pthread_t thread)
/* ARGSUSED */
static int
-pthread_join(sp_pthread_t thread, void **value)
+pthread2_join(sp_pthread_t thread, void **value)
{
int status;
@@ -510,7 +510,7 @@ sshpam_thread(void *ctxtp)
/* XXX - can't do much about an error here */
ssh_msg_send(ctxt->pam_csock, sshpam_err, &buffer);
buffer_free(&buffer);
- pthread_exit(NULL);
+ pthread2_exit(NULL);
auth_fail:
buffer_put_cstring(&buffer,
@@ -521,7 +521,7 @@ sshpam_thread(void *ctxtp)
else
ssh_msg_send(ctxt->pam_csock, PAM_AUTH_ERR, &buffer);
buffer_free(&buffer);
- pthread_exit(NULL);
+ pthread2_exit(NULL);
return (NULL); /* Avoid warning for non-pthread case */
}
@@ -533,8 +533,8 @@ sshpam_thread_cleanup(void)
debug3("PAM: %s entering", __func__);
if (ctxt != NULL && ctxt->pam_thread != 0) {
- pthread_cancel(ctxt->pam_thread);
- pthread_join(ctxt->pam_thread, NULL);
+ pthread2_cancel(ctxt->pam_thread);
+ pthread2_join(ctxt->pam_thread, NULL);
close(ctxt->pam_psock);
close(ctxt->pam_csock);
memset(ctxt, 0, sizeof(*ctxt));
@@ -698,7 +698,7 @@ sshpam_init_ctx(Authctxt *authctxt)
}
ctxt->pam_psock = socks[0];
ctxt->pam_csock = socks[1];
- if (pthread_create(&ctxt->pam_thread, NULL, sshpam_thread, ctxt) == -1) {
+ if (pthread2_create(&ctxt->pam_thread, NULL, sshpam_thread, ctxt) == -1) {
error("PAM: failed to start authentication thread: %s",
strerror(errno));
close(socks[0]);

Loading…
Cancel
Save