Browse Source

mjpg-streamer: Remove build date-time from image

Remove un-needed uvcvideo.h (use system include)

Signed-off-by: Ted Hess <thess@kitschensync.net>
lilik-openwrt-22.03
Ted Hess 7 years ago
parent
commit
9be0710ebd
2 changed files with 39 additions and 1 deletions
  1. +5
    -1
      multimedia/mjpg-streamer/Makefile
  2. +34
    -0
      multimedia/mjpg-streamer/patches/035-remove_build_date-time.patch

+ 5
- 1
multimedia/mjpg-streamer/Makefile View File

@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mjpg-streamer
PKG_REV:=182
PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=9
PKG_RELEASE:=10
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>, \
Ted Hess <thess@kitschensync.net>
@ -71,6 +71,10 @@ define Build/Prepare
endif
endef
define Build/Configure
$(RM) $(PKG_BUILD_DIR)/plugins/input_uvc/uvcvideo.h
endef
ifeq ($(CONFIG_MJPG_STREAMER_V4L2),y)
TARGET_CFLAGS+= -DUSE_LIBV4L2
TARGET_LDFLAGS+= -lv4l2


+ 34
- 0
multimedia/mjpg-streamer/patches/035-remove_build_date-time.patch View File

@ -0,0 +1,34 @@
--- a/Makefile
+++ b/Makefile
@@ -15,8 +15,8 @@ DESTDIR = /usr/local
# set the compiler to use
CC = gcc
-SVNDEV := -D'SVN_REV="$(shell svnversion -c .)"'
-CFLAGS += $(SVNDEV)
+#SVNDEV := -D'SVN_REV="$(shell svnversion -c .)"'
+#CFLAGS += $(SVNDEV)
# general compile flags, enable all warnings to make compile more verbose
CFLAGS += -DLINUX -D_GNU_SOURCE -Wall
--- a/mjpg_streamer.c
+++ b/mjpg_streamer.c
@@ -253,15 +253,12 @@ int main(int argc, char *argv[])
/* v, version */
case 6:
case 7:
- printf("MJPG Streamer Version: %s\n" \
- "Compilation Date.....: %s\n" \
- "Compilation Time.....: %s\n",
+ printf("MJPG Streamer Version: %s\n",
#ifdef SVN_REV
- SVN_REV,
+ SVN_REV);
#else
- SOURCE_VERSION,
+ SOURCE_VERSION);
#endif
- __DATE__, __TIME__);
return 0;
break;

Loading…
Cancel
Save