Browse Source

libzdb: remove

Does not seem to be used.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
9b4308dae6
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 0 additions and 119 deletions
  1. +0
    -89
      libs/libzdb/Makefile
  2. +0
    -19
      libs/libzdb/patches/010-do-not-run-test-progs.patch
  3. +0
    -11
      libs/libzdb/patches/020-filterh-use-host-built-version.patch

+ 0
- 89
libs/libzdb/Makefile View File

@ -1,89 +0,0 @@
#
# Copyright (C) 2007-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libzdb
PKG_VERSION:=3.2.1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.tildeslash.com/libzdb/dist/
PKG_HASH:=b9a7b59a0a9f53dc87ce1b5a919f21b8cd6448c04a9157bccef1e3c1dffd3ff1
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=libzdb/host
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
# libzdb needs to find iconv when linking to libmariadb
include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/host-build.mk
define Package/libzdb
SECTION:=libs
CATEGORY:=Libraries
TITLE:=A thread-safe multi database connection pool library
URL:=https://www.tildeslash.com/libzdb/
DEPENDS:=+libsqlite3 +libpq +libmysqlclient +zlib +libpthread +libopenssl
endef
define Package/libzdb/description
zdb is a database library with thread-safe connection pooling. The library can connect
transparently to multiple database systems. It has zero runtime configuration and connections
are specified via a URL scheme. A modern object-oriented API is provided.
zdb supports MySQL, PostgreSQL, SQLite, and Oracle.
NOTE: This package does not include Oracle support.
endef
CONFIGURE_ARGS += \
--disable-profiling \
--enable-optimized \
--enable-protected \
--enable-sqliteunlock \
--enable-openssl
CONFIGURE_VARS += \
libzdb_cv_setjmp_available=yes \
libzdb_cv_vsnprintf_c11_conformant=yes
define Hooks/HostConfigure/Pre
endef
define Host/Configure
endef
define Host/Compile
$(HOSTCC) $(HOST_BUILD_DIR)/tools/filterh/lex.yy.c -o $(HOST_BUILD_DIR)/tools/bin/filterh
endef
define Host/Install
$(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/bin
$(INSTALL_BIN) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR_HOSTPKG)/bin
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/zdb
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/zdb/* $(1)/usr/include/zdb
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libzdb* $(1)/usr/lib
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/zdb.pc $(1)/usr/lib/pkgconfig
endef
define Package/libzdb/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libzdb.so* $(1)/usr/lib
endef
$(eval $(call HostBuild))
$(eval $(call BuildPackage,libzdb))

+ 0
- 19
libs/libzdb/patches/010-do-not-run-test-progs.patch View File

@ -1,19 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -454,16 +454,6 @@ if test $ondarwin -eq 1; then
else
stdc="gnu"
fi
-AC_RUN_IFELSE(
-[AC_LANG_PROGRAM([], [dnl
- #ifdef __STDC_VERSION__
- #if __STDC_VERSION__ >= 201112L
- return 0;
- #endif
- #endif
- return 1;
- ])], [CFLAGS="$CFLAGS -std=${stdc}11"], [CFLAGS="$CFLAGS -std=${stdc}99"])
-AC_CHECK_HEADERS([stdint.h stdbool.h], [], [AC_MSG_ERROR([toolchain does not have C99 headers])])
# ---------------------------------------------------------------------------
# Outputs

+ 0
- 11
libs/libzdb/patches/020-filterh-use-host-built-version.patch View File

@ -1,11 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,7 @@ LIBRARY_NAME = zdb
RE2C = @RE2C@
RE2CFLAGS = -b
-FILTERH = ./tools/bin/filterh
+FILTERH = $(STAGING_DIR_HOSTPKG)/bin/filterh
AM_CPPFLAGS = $(CPPFLAGS) $(DBCPPFLAGS)
AM_CPPFLAGS += -Isrc -Isrc/util -Isrc/net -Isrc/db -Isrc/db/oracle -Isrc/exceptions

Loading…
Cancel
Save