Browse Source

openvswitch: fix build with musl and GCC 5

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 9 years ago
parent
commit
9afb25cc5a
2 changed files with 14 additions and 14 deletions
  1. +1
    -1
      net/openvswitch/Makefile
  2. +13
    -13
      net/openvswitch/patches/0004-musl-compatibility.patch

+ 1
- 1
net/openvswitch/Makefile View File

@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvswitch
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_VERSION:=2.4.0
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_LICENSE:=Apache-2.0


+ 13
- 13
net/openvswitch/patches/0004-musl-compatibility.patch View File

@ -1,8 +1,8 @@
diff --git a/configure.ac b/configure.ac
index 8d47eb9..69eeed8 100644
index e6a23a6..8a7c6d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,7 +117,6 @@ OVS_CHECK_XENSERVER_VERSION
@@ -118,7 +118,6 @@ OVS_CHECK_XENSERVER_VERSION
OVS_CHECK_GROFF
OVS_CHECK_GNU_MAKE
OVS_CHECK_TLS
@ -11,7 +11,7 @@ index 8d47eb9..69eeed8 100644
OVS_CHECK_ATOMIC_ALWAYS_LOCK_FREE(1)
OVS_CHECK_ATOMIC_ALWAYS_LOCK_FREE(2)
diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
index 9b2e74f..70126bb 100644
index 712cb5a..e840f10 100644
--- a/lib/netdev-linux.c
+++ b/lib/netdev-linux.c
@@ -40,7 +40,9 @@
@ -25,15 +25,15 @@ index 9b2e74f..70126bb 100644
#include <netinet/in.h>
#include <poll.h>
diff --git a/lib/ovs-atomic.h b/lib/ovs-atomic.h
index 9ead907..86d3341 100644
index 9ead907..0a131d7 100644
--- a/lib/ovs-atomic.h
+++ b/lib/ovs-atomic.h
@@ -325,8 +325,6 @@
#include "ovs-atomic-clang.h"
#elif HAVE_STDATOMIC_H
#include "ovs-atomic-c11.h"
- #elif __GNUC__ >= 4 && __GNUC_MINOR__ >= 7
- #include "ovs-atomic-gcc4.7+.h"
#elif __GNUC__ && defined(__x86_64__)
#include "ovs-atomic-x86_64.h"
#elif __GNUC__ && defined(__i386__)
@@ -318,7 +318,7 @@
#include "util.h"
#define IN_OVS_ATOMIC_H
- #if __CHECKER__
+ #if 1
/* sparse doesn't understand some GCC extensions we use. */
#include "ovs-atomic-pthreads.h"
#elif __has_extension(c_atomic)

Loading…
Cancel
Save