Browse Source

sound/lame: Update to 3.100

* Update LAME to 3.100

* Switch to shared library instead of static binary as it adds very little
  overhead if you only need LAME binary but saves space if you need both
  library and binary.

  Static / Shared:
  LAME binary: ~252kbyte / ~72kbyte - IPK: ~138kbyte / ~34kbyte
  LAME library: ~216kbyte / ~216kbyte - IPK: ~117kbyte / ~117kbyte

* Drop patch, not needed

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
lilik-openwrt-22.03
Daniel Engberg 7 years ago
parent
commit
9a9e71e533
2 changed files with 6 additions and 39 deletions
  1. +6
    -6
      sound/lame/Makefile
  2. +0
    -33
      sound/lame/patches/001-automake-compat.patch

+ 6
- 6
sound/lame/Makefile View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=lame PKG_NAME:=lame
PKG_VERSION:=3.99.5
PKG_RELEASE:=2
PKG_VERSION:=3.100
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/lame PKG_SOURCE_URL:=@SF/lame
PKG_HASH:=24346b4158e4af3bd9f2e194bb23eb473c75fb7377011523353196b19b9a23ff
PKG_HASH:=ddfe36cab873794038ae2c1210557ad34857a4b6bdc515785d1da9e175b1da1e
PKG_FIXUP:=autoreconf PKG_FIXUP:=autoreconf
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net> PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
@ -36,7 +36,7 @@ define Package/lame
$(call Package/lame/Default) $(call Package/lame/Default)
TITLE:=lame TITLE:=lame
MENU:=1 MENU:=1
DEPENDS += +libncurses
DEPENDS += +libncurses +lame-lib
endef endef
define Package/lame/description define Package/lame/description
@ -52,12 +52,12 @@ define Package/lame-lib/description
lame mp3 encoder libs lame mp3 encoder libs
endef endef
CONFIG_VARS+=NASM=no
ifeq ($(ARCH),i386) ifeq ($(ARCH),i386)
TARGET_CFLAGS+=-msse TARGET_CFLAGS+=-msse
endif endif
CONFIGURE_ARGS += --disable-gtktest --disable-static
define Package/lame/install define Package/lame/install
$(INSTALL_DIR) $(1)/usr/bin $(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lame $(1)/usr/bin/ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lame $(1)/usr/bin/


+ 0
- 33
sound/lame/patches/001-automake-compat.patch View File

@ -1,33 +0,0 @@
--- a/configure.in
+++ b/configure.in
@@ -393,7 +393,7 @@ CONFIG_MATH_LIB="${USE_LIBM}"
dnl configure use of features
-AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
+HAVE_GTK="no"
dnl ElectricFence malloc debugging
AC_MSG_CHECKING(use of ElectricFence malloc debugging)
--- a/frontend/Makefile.am
+++ b/frontend/Makefile.am
@@ -35,7 +35,7 @@ lame_SOURCES = lame_main.c $(common_sour
mp3rtp_SOURCES = mp3rtp.c rtp.c $(common_sources)
mp3x_SOURCES = mp3x.c gtkanal.c gpkplotting.c $(common_sources)
-CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
+CFLAGS = @CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@
INCLUDES = -I$(top_srcdir)/libmp3lame -I$(top_srcdir)/include -I$(top_builddir)
--- a/frontend/Makefile.in
+++ b/frontend/Makefile.in
@@ -99,7 +99,7 @@ AUTOMAKE = @AUTOMAKE@
AWK = @AWK@
CC = @CC@
CCDEPMODE = @CCDEPMODE@
-CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
+CFLAGS = @CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
CONFIG_DEFS = @CONFIG_DEFS@
CONFIG_MATH_LIB = @CONFIG_MATH_LIB@
CPP = @CPP@

Loading…
Cancel
Save