This website works better with JavaScript.
Home
Help
Sign In
LILiK
/
openwrt-packages-dist
Watch
5
Star
0
Fork
0
Code
Issues
0
Pull Requests
0
Projects
0
Releases
0
Wiki
Activity
Browse Source
inadyn: Fix compilation without deprecated OpenSSL APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
6 years ago
parent
483c9fceae
commit
99c54c97e4
2 changed files
with
25 additions
and
1 deletions
Split View
Diff Options
Show Stats
Download Patch File
Download Diff File
+1
-1
net/inadyn/Makefile
+24
-0
net/inadyn/patches/010-openssl-deprecated.patch
+ 1
- 1
net/inadyn/Makefile
View File
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME
:=
inadyn
PKG_VERSION
:=
2.3.1
PKG_RELEASE
:=
1
PKG_RELEASE
:=
2
PKG_MAINTAINER
:=
PKG_LICENSE
:=
GPL-2.0
PKG_LICENSE_FILES
:=
COPYING
+ 24
- 0
net/inadyn/patches/010-openssl-deprecated.patch
View File
@ -0,0 +1,24 @@
--- a/src/openssl.c
+++ b/src/openssl.c
@@ -25,17 +25,21 @@
int ssl_init(void)
{
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
SSL_library_init();
SSL_load_error_strings();
OpenSSL_add_all_algorithms();
+#endif
return 0;
}
void ssl_exit(void)
{
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
ERR_free_strings();
EVP_cleanup();
+#endif
}
static int verify_callback(int preverify_ok, X509_STORE_CTX *ctx)
Write
Preview
Loading…
Cancel
Save