Browse Source

mpd: Update to 0.19.14, disable soxr

Signed-off-by: Ted Hess <thess@kitschensync.net>
lilik-openwrt-22.03
Ted Hess 8 years ago
parent
commit
99a49889a1
2 changed files with 4 additions and 25 deletions
  1. +4
    -3
      sound/mpd/Makefile
  2. +0
    -22
      sound/mpd/patches/100-musl_gcc5_fixes.patch

+ 4
- 3
sound/mpd/Makefile View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007-2015 OpenWrt.org
# Copyright (C) 2007-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mpd
PKG_VERSION:=0.19.11
PKG_VERSION:=0.19.14
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.19/
PKG_MD5SUM:=78935f6c464b67e19b4dc65bdb80319e
PKG_MD5SUM:=9f99340ec6b77bea4ba3729e3b76fd7c
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-2.0
@ -137,6 +137,7 @@ CONFIGURE_ARGS += \
--disable-wildmidi \
--disable-zzip \
--with-zeroconf=no \
--disable-soxr \
\
--enable-curl \
--enable-flac \


+ 0
- 22
sound/mpd/patches/100-musl_gcc5_fixes.patch View File

@ -26,25 +26,3 @@ Volatile in the type is necessary. without that, LTO can break the code.
constexpr
#endif
notify():pending(false) {}
--- a/src/thread/PosixCond.hxx
+++ b/src/thread/PosixCond.hxx
@@ -41,7 +41,7 @@ class PosixCond {
pthread_cond_t cond;
public:
-#if defined(__NetBSD__) || defined(__BIONIC__)
+#if !defined(__GLIBC__)
/* NetBSD's PTHREAD_COND_INITIALIZER is not compatible with
"constexpr" */
PosixCond() {
--- a/src/thread/PosixMutex.hxx
+++ b/src/thread/PosixMutex.hxx
@@ -41,7 +41,7 @@ class PosixMutex {
pthread_mutex_t mutex;
public:
-#if defined(__NetBSD__) || defined(__BIONIC__)
+#if !defined(__GLIBC__)
/* NetBSD's PTHREAD_MUTEX_INITIALIZER is not compatible with
"constexpr" */
PosixMutex() {

Loading…
Cancel
Save