Browse Source

Merge pull request #7051 from commodo/python3-fix-ssl-dh-free

python3: fix build with SSL module
lilik-openwrt-22.03
Hannu Nyman 6 years ago
committed by GitHub
parent
commit
985dd0de78
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 13 additions and 1 deletions
  1. +1
    -1
      lang/python/python3/Makefile
  2. +12
    -0
      lang/python/python3/patches/002-fix-implicit-dh-free-declaration.patch

+ 1
- 1
lang/python/python3/Makefile View File

@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
PKG_NAME:=python3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz


+ 12
- 0
lang/python/python3/patches/002-fix-implicit-dh-free-declaration.patch View File

@ -0,0 +1,12 @@
diff --git a/Modules/_ssl.c b/Modules/_ssl.c
index 2bce4816d2..3c93884809 100644
--- a/Modules/_ssl.c
+++ b/Modules/_ssl.c
@@ -63,6 +63,7 @@ static PySocketModule_APIObject PySocketModule;
#include "openssl/err.h"
#include "openssl/rand.h"
#include "openssl/bio.h"
+#include "openssl/dh.h"
#ifndef HAVE_X509_VERIFY_PARAM_SET1_HOST
# ifdef LIBRESSL_VERSION_NUMBER

Loading…
Cancel
Save