@ -21,14 +21,14 @@
+ if grep uuid_generate /usr/include/uuid/uuid.h > /dev/null 2>&1 ; then
+ if grep uuid_generate /usr/include/uuid/uuid.h > /dev/null 2>&1 ; then
+ echo "#define LIB_UUID" >> ${CONFIGFILE}
+ echo "#define LIB_UUID" >> ${CONFIGFILE}
+ fi
+ fi
+ ;;
+ ;;
+esac
+esac
# set V6SOCKETS_ARE_V6ONLY to 0 if it was not set above
# set V6SOCKETS_ARE_V6ONLY to 0 if it was not set above
if [ -z "$V6SOCKETS_ARE_V6ONLY" ] ; then
if [ -z "$V6SOCKETS_ARE_V6ONLY" ] ; then
--- a/Makefile.linux
--- a/Makefile.linux
+++ b/Makefile.linux
+++ b/Makefile.linux
@@ -74,7 +74 ,10 @@ CPPFLAGS += -DIPTABLES_143
@@ -77,7 +77 ,10 @@ CPPFLAGS += -DIPTABLES_143
endif
endif
CFLAGS += $(shell $(PKG_CONFIG) --cflags libiptc)
CFLAGS += $(shell $(PKG_CONFIG) --cflags libiptc)
@ -39,7 +39,7 @@
LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L libiptc)
LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L libiptc)
LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-other libiptc)
LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-other libiptc)
else
else
@@ -154,6 +157 ,8 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
@@ -157,6 +160 ,8 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libnetfilter_conntrack)
LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libnetfilter_conntrack)
endif # ($(TEST),1)
endif # ($(TEST),1)
@ -48,11 +48,11 @@
LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libssl)
LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libssl)
TEST := $(shell $(PKG_CONFIG) --exists uuid && echo 1)
TEST := $(shell $(PKG_CONFIG) --exists uuid && echo 1)
@@ -162,6 +167 ,7 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
@@ -165,6 +170 ,7 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
else
else
$(info please install uuid-dev package / libuuid)
$(info please install uuid-dev package / libuuid)
endif # ($(TEST),1)
endif # ($(TEST),1)
+endif # ($(TARGET_OPENWRT,)
+endif # ($(TARGET_OPENWRT,)
TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o
GLIBC_VERSION := $(shell ldd --version | head -n 1 | sed 's/^.* //')
GLIBC_VERSION_MAJOR = $(shell echo $(GLIBC_VERSION) | cut -f 1 -d . )