Browse Source

python-cryptography: Fix failing build

Fixes https://github.com/openwrt/packages/issues/18876.
Fixes https://github.com/openwrt/packages/issues/18879.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 9e3b7d7883)
lilik-openwrt-22.03
Jeffery To 2 years ago
committed by Rosen Penev
parent
commit
953e29f067
2 changed files with 6 additions and 3 deletions
  1. +1
    -1
      lang/python/python-cryptography/Makefile
  2. +5
    -2
      lang/python/python-cryptography/patches/0004-disable-rust.patch

+ 1
- 1
lang/python/python-cryptography/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography
PKG_VERSION:=3.4.8
PKG_RELEASE:=1
PKG_RELEASE:=2
PYPI_NAME:=cryptography
PKG_HASH:=94cc5ed4ceaefcbe5bf38c8fba6a21fc1d365bb8fb826ea1688e3370b2e24a1c


+ 5
- 2
lang/python/python-cryptography/patches/0004-disable-rust.patch View File

@ -9,9 +9,12 @@
except ImportError:
print(
"""
@@ -45,7 +45,7 @@ setuptools_rust = "setuptools-rust>=0.11
@@ -43,9 +43,9 @@ with open(os.path.join(src_dir, "cryptog
# `pyproject.toml`
setuptools_rust = "setuptools-rust>=0.11.4"
install_requirements = ["cffi>=1.12"]
setup_requirements = install_requirements + [setuptools_rust]
-setup_requirements = install_requirements + [setuptools_rust]
+setup_requirements = install_requirements
-if os.environ.get("CRYPTOGRAPHY_DONT_BUILD_RUST"):
+if True:


Loading…
Cancel
Save