Browse Source

readsb: fix compilation with GCC10

Upstream backport.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
94eacb36ea
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 62 additions and 1 deletions
  1. +1
    -1
      utils/readsb/Makefile
  2. +61
    -0
      utils/readsb/patches/010-gcc10.patch

+ 1
- 1
utils/readsb/Makefile View File

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=readsb
PKG_VERSION:=3.8.3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/Mictronics/readsb/tar.gz/v$(PKG_VERSION)?


+ 61
- 0
utils/readsb/patches/010-gcc10.patch View File

@ -0,0 +1,61 @@
From 5119c21ae56f1c7fd0b10250d1beca9634bf74af Mon Sep 17 00:00:00 2001
From: Mictronics <github@mictronics.de>
Date: Sun, 14 Jun 2020 18:06:22 +0200
Subject: [PATCH] Clean up linkage of struct Modes.
---
readsb.c | 2 ++
readsb.h | 6 ++++--
viewadsb.c | 2 ++
3 files changed, 8 insertions(+), 2 deletions(-)
diff --git a/readsb.c b/readsb.c
index e784d891..d6dab324 100644
--- a/readsb.c
+++ b/readsb.c
@@ -57,6 +57,8 @@
#include <stdarg.h>
+struct _Modes Modes;
+
//
// ============================= Program options help ==========================
//
diff --git a/readsb.h b/readsb.h
index 3a1b22d5..1b80c338 100644
--- a/readsb.h
+++ b/readsb.h
@@ -312,7 +312,7 @@ struct mag_buf
// Program global state
-struct
+struct _Modes
{ // Internal state
pthread_cond_t data_cond; // Conditional variable associated
pthread_t reader_thread;
@@ -412,7 +412,9 @@ struct
struct stats stats_15min;
struct timespec reader_cpu_accumulator; // CPU time used by the reader thread, copied out and reset by the main thread under the mutex
struct mag_buf mag_buffers[MODES_MAG_BUFFERS]; // Converted magnitude buffers from RTL or file input
-} Modes;
+};
+
+extern struct _Modes Modes;
// The struct we use to store information about a decoded message.
diff --git a/viewadsb.c b/viewadsb.c
index ad7b1bd0..915305b6 100644
--- a/viewadsb.c
+++ b/viewadsb.c
@@ -54,6 +54,8 @@
#include "readsb.h"
#include "help.h"
+struct _Modes Modes;
+
#define _stringize(x) x
#define verstring(x) _stringize(x)

Loading…
Cancel
Save