Browse Source

opendoas: add package

Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
(cherry picked from commit ad7d2e5270)
lilik-openwrt-22.03
Michal Vasilek 2 years ago
committed by Josef Schlehofer
parent
commit
94821d9c07
No known key found for this signature in database GPG Key ID: B950216FE4329F4C
3 changed files with 61 additions and 0 deletions
  1. +40
    -0
      utils/opendoas/Makefile
  2. +11
    -0
      utils/opendoas/patches/configure-ignore-invalid-arguments.patch
  3. +10
    -0
      utils/opendoas/patches/makefile-remove-chown.patch

+ 40
- 0
utils/opendoas/Makefile View File

@ -0,0 +1,40 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=opendoas
PKG_VERSION:=6.8.2
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/Duncaen/OpenDoas/releases/download/v$(PKG_VERSION)
PKG_HASH:=4e98828056d6266bd8f2c93e6ecf12a63a71dbfd70a5ea99ccd4ab6d0745adf0
PKG_MAINTAINER:=Michal Vasilek <michal.vasilek@nic.cz>
PKG_LICENSE:=ISC, BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
define Package/opendoas
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Portable OpenBSD doas to execute commands as another user
URL:=https://github.com/Duncaen/OpenDoas
endef
define Package/opendoas/description
OpenDoas: a portable version of OpenBSD's doas command
doas is a minimal replacement for the venerable sudo. It was initially
written by Ted Unangst of the OpenBSD project to provide 95% of the features
of sudo with a fraction of the codebase.
endef
define Package/opendoas/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/doas $(1)/usr/bin/
endef
$(eval $(call BuildPackage,opendoas))

+ 11
- 0
utils/opendoas/patches/configure-ignore-invalid-arguments.patch View File

@ -0,0 +1,11 @@
--- a/configure
+++ b/configure
@@ -67,7 +67,7 @@ for x; do
--uid-max) UID_MAX=$var ;;
--gid-max) UID_MAX=$var ;;
--help|-h) usage ;;
- *) die "Error: unknown option $opt" ;;
+ *) echo "Error: unknown option $opt" ;;
esac
done

+ 10
- 0
utils/opendoas/patches/makefile-remove-chown.patch View File

@ -0,0 +1,10 @@
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -21,7 +21,6 @@ install: ${PROG} ${PAM_DOAS} ${MAN}
mkdir -p -m 0755 ${DESTDIR}${MANDIR}/man1
mkdir -p -m 0755 ${DESTDIR}${MANDIR}/man5
cp -f ${PROG} ${DESTDIR}${BINDIR}
- chown ${BINOWN}:${BINGRP} ${DESTDIR}${BINDIR}/${PROG}
chmod ${BINMODE} ${DESTDIR}${BINDIR}/${PROG}
[ -n "${PAM_DOAS}" ] && cp ${PAM_DOAS} ${DESTDIR}${PAMDIR}/doas || true
[ -n "${PAM_DOAS}" ] && chmod 0644 ${DESTDIR}${PAMDIR}/doas || true

Loading…
Cancel
Save