Browse Source

Merge pull request #12701 from neheb/apf

apfree-wifidog: fix compilation with GCC10
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
9464d4171d
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 37 additions and 1 deletions
  1. +1
    -1
      net/apfree-wifidog/Makefile
  2. +36
    -0
      net/apfree-wifidog/patches/020-gcc10.patch

+ 1
- 1
net/apfree-wifidog/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=apfree-wifidog
PKG_VERSION:=3.11.1716
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/liudf0716/apfree_wifidog.git


+ 36
- 0
net/apfree-wifidog/patches/020-gcc10.patch View File

@ -0,0 +1,36 @@
--- a/src/conf.h
+++ b/src/conf.h
@@ -430,12 +430,12 @@ void clear_trusted_ip_list(void);
void del_trusted_ip_list(const char *);
// online clients
-int g_online_clients; // total connected client count
-char *g_version;
-char *g_type; // hardware type
-char *g_name; // firmware name
-char *g_channel_path;
-char *g_ssid;
+extern int g_online_clients; // total connected client count
+extern char *g_version;
+extern char *g_type; // hardware type
+extern char *g_name; // firmware name
+extern char *g_channel_path;
+extern char *g_ssid;
#define LOCK_DOMAIN() do { \
debug(LOG_INFO, "Locking domain"); \
--- a/src/ping_thread.c
+++ b/src/ping_thread.c
@@ -43,6 +43,12 @@
#include "wd_client.h"
extern time_t started_time;
+int g_online_clients;
+char *g_version;
+char *g_type;
+char *g_name;
+char *g_channel_path;
+char *g_ssid;
static void fw_init_delay();
static void ping_work_cb(evutil_socket_t, short, void *);

Loading…
Cancel
Save