Browse Source
nspr: fix compilation with newer musl
Include proper sgidefs define.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
5 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
12 additions and
1 deletions
-
libs/nspr/Makefile
-
libs/nspr/patches/010-sgidefs.patch
|
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=nspr |
|
|
|
PKG_VERSION:=4.25 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com> |
|
|
|
PKG_LICENCE:=MPL-2.0 |
|
|
|
|
|
|
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
--- a/nspr/pr/include/md/_linux.cfg
|
|
|
|
+++ b/nspr/pr/include/md/_linux.cfg
|
|
|
|
@@ -499,7 +499,7 @@
|
|
|
|
#elif defined(__mips__) |
|
|
|
|
|
|
|
/* For _ABI64 */ |
|
|
|
-#include <sgidefs.h>
|
|
|
|
+#include <asm/sgidefs.h>
|
|
|
|
|
|
|
|
#ifdef __MIPSEB__ |
|
|
|
#define IS_BIG_ENDIAN 1 |