Browse Source
uwsgi-cgi: Fix compilation under uClibc-ng
execinfo.h is missing.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
6 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
12 additions and
1 deletions
-
net/uwsgi-cgi/Makefile
-
net/uwsgi-cgi/patches/010-uclibc-ng.patch
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=uwsgi-cgi |
|
|
PKG_NAME:=uwsgi-cgi |
|
|
PKG_VERSION:=2.0.18 |
|
|
PKG_VERSION:=2.0.18 |
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
|
PKG_SOURCE_URL= \
|
|
|
PKG_SOURCE_URL= \
|
|
|
https://projects.unbit.it/downloads \
|
|
|
https://projects.unbit.it/downloads \
|
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
|
|
--- a/core/uwsgi.c
|
|
|
|
|
|
+++ b/core/uwsgi.c
|
|
|
|
|
|
@@ -1820,7 +1820,7 @@ void uwsgi_plugins_atexit(void) {
|
|
|
|
|
|
|
|
|
|
|
|
void uwsgi_backtrace(int depth) { |
|
|
|
|
|
|
|
|
|
|
|
-#if defined(__GLIBC__) || (defined(__APPLE__) && !defined(NO_EXECINFO)) || defined(UWSGI_HAS_EXECINFO)
|
|
|
|
|
|
+#if (!defined(__UCLIBC__) && defined(__GLIBC__)) || (defined(__APPLE__) && !defined(NO_EXECINFO)) || defined(UWSGI_HAS_EXECINFO)
|
|
|
|
|
|
|
|
|
|
|
|
#include <execinfo.h> |
|
|
|
|
|
|