Browse Source

libextractor: build giflib plugin

Cherry-picked r34095 'Add giflib-5.1.0 compatibility' into patches to
fix build against recent versions of giflib.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
lilik-openwrt-22.03
Daniel Golle 9 years ago
parent
commit
939f2e2dc5
2 changed files with 29 additions and 2 deletions
  1. +3
    -2
      libs/libextractor/Makefile
  2. +26
    -0
      libs/libextractor/patches/001-backport-support-for-giflib-5-1.patch

+ 3
- 2
libs/libextractor/Makefile View File

@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libextractor
PKG_VERSION:=1.3
PKG_RELEASE:=2
PKG_RELEASE:=3
# ToDo:
# - package missing optional dependencies: libexiv2, giflib, gsf, librpm, smf, tidy
# - package missing optional dependencies: libexiv2, gsf, librpm, smf, tidy
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@ -29,6 +29,7 @@ PLUGINS:= \
deb \
dvi \
flac:+libflac \
gif:+giflib \
gstreamer:+libgstreamer1:+libgst1app:+libgst1pbutils:+libgst1tag \
it \
jpeg:+libjpeg \


+ 26
- 0
libs/libextractor/patches/001-backport-support-for-giflib-5-1.patch View File

@ -0,0 +1,26 @@
--- a/src/plugins/gif_extractor.c
+++ b/src/plugins/gif_extractor.c
@@ -78,7 +78,11 @@ EXTRACTOR_gif_extract_method (struct EXT
if (gif_file == NULL || gif_error != 0)
{
if (gif_file != NULL)
+#if GIFLIB_MAJOR < 5 || GIFLIB_MINOR < 1
EGifCloseFile (gif_file);
+#else
+ EGifCloseFile (gif_file, NULL);
+#endif
return; /* not a GIF */
}
#endif
@@ -133,7 +137,11 @@ EXTRACTOR_gif_extract_method (struct EXT
DGifGetExtensionNext(gif_file, &ext)) &&
(NULL != ext) ) ; /* keep going */
}
+#if defined (GIF_LIB_VERSION) || GIFLIB_MAJOR < 5 || GIFLIB_MINOR < 1
DGifCloseFile (gif_file);
+#else
+ DGifCloseFile (gif_file, NULL);
+#endif
}
/* end of gif_extractor.c */

Loading…
Cancel
Save