Browse Source

transmission: update to 3.0

remove upstreamed patches. Refresh remaining one.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
93485dd317
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
7 changed files with 8 additions and 149 deletions
  1. +3
    -3
      net/transmission/Makefile
  2. +0
    -30
      net/transmission/patches/010-fix-port-test.patch
  3. +0
    -26
      net/transmission/patches/020-fix-safari.patch
  4. +0
    -31
      net/transmission/patches/030-fix-dht-memory-leak.patch
  5. +0
    -29
      net/transmission/patches/040-fix-curl.patch
  6. +0
    -25
      net/transmission/patches/070-uClibc-ng-since-1.0.18-has-sys-quota.h-synced-with-G.patch
  7. +5
    -5
      net/transmission/patches/080-disable-webseeding.patch

+ 3
- 3
net/transmission/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=2.94
PKG_RELEASE:=16
PKG_VERSION:=3.00
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
PKG_HASH:=35442cc849f91f8df982c3d0d479d650c6ca19310a994eccdaa79a4af3916b7d
PKG_HASH:=9144652fe742f7f7dd6657716e378da60b751aaeda8bef8344b3eefc4db255f2
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later


+ 0
- 30
net/transmission/patches/010-fix-port-test.patch View File

@ -1,30 +0,0 @@
From d6655cca7db1b960456811b8206ce222700e010d Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Tue, 30 Jan 2018 13:19:58 -0800
Subject: [PATCH] Remove compressed responses from web servers.
While zlib is mandatory for transmission, it is not mandatory for curl.
A libcurl that has been compiled with no support for zlib will return no data if compressed responses are set to on.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
libtransmission/web.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libtransmission/web.c b/libtransmission/web.c
index c7f0627..db34976 100644
--- a/libtransmission/web.c
+++ b/libtransmission/web.c
@@ -180,7 +180,7 @@ createEasy (tr_session * s, struct tr_web * web, struct tr_web_task * task)
task->timeout_secs = getTimeoutFromURL (task);
curl_easy_setopt (e, CURLOPT_AUTOREFERER, 1L);
- curl_easy_setopt (e, CURLOPT_ENCODING, "gzip;q=1.0, deflate, identity");
+ curl_easy_setopt (e, CURLOPT_ENCODING, "");
curl_easy_setopt (e, CURLOPT_FOLLOWLOCATION, 1L);
curl_easy_setopt (e, CURLOPT_MAXREDIRS, -1L);
curl_easy_setopt (e, CURLOPT_NOSIGNAL, 1L);
--
2.7.4

+ 0
- 26
net/transmission/patches/020-fix-safari.patch View File

@ -1,26 +0,0 @@
From 405d768bfea661c418e2c75686a7bac95e4bb17b Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Thu, 1 Mar 2018 11:25:15 -0800
Subject: [PATCH] fix web interface with Safari.
Backport of bcfe147e6a41ce7774f569ede6179a7ed2c7f560
---
web/javascript/common.js | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/web/javascript/common.js b/web/javascript/common.js
index 7162d3f82..77bf96857 100644
--- a/web/javascript/common.js
+++ b/web/javascript/common.js
@@ -61,7 +61,7 @@ $(document).ready(function() {
// Fix min height for isMobileDevice when run in full screen mode from home screen
// so the footer appears in the right place
$('body div#torrent_container').css('min-height', '338px');
- $("label[for=torrent_upload_url]").text("URL: ");
+ $("label[for=torrent_upload_url]").text = "URL: ";
} else {
// Fix for non-Safari-3 browsers: dark borders to replace shadows.
$('div.dialog_container div.dialog_window').css('border', '1px solid #777');
--
2.14.3

+ 0
- 31
net/transmission/patches/030-fix-dht-memory-leak.patch View File

@ -1,31 +0,0 @@
From df03e037c69ebd74dd2db77d034b65980f0dc2d0 Mon Sep 17 00:00:00 2001
From: Mike Gelfand <mikedld@mikedld.com>
Date: Tue, 23 Jan 2018 21:20:30 +0300
Subject: [PATCH] Fix memory leak in `tr_dhtInit` in failure condition
Fixes: #482
---
libtransmission/tr-dht.c | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/libtransmission/tr-dht.c b/libtransmission/tr-dht.c
index 243429f64..df56542bc 100644
--- a/libtransmission/tr-dht.c
+++ b/libtransmission/tr-dht.c
@@ -333,8 +333,11 @@ tr_dhtInit (tr_session *ss)
return 1;
- fail:
- tr_logAddNamedDbg ("DHT", "DHT initialization failed (errno = %d)", errno);
+fail:
+ tr_free(nodes6);
+ tr_free(nodes);
+
+ tr_logAddNamedDbg("DHT", "DHT initialization failed (errno = %d)", errno);
session = NULL;
return -1;
}
--
2.17.0

+ 0
- 29
net/transmission/patches/040-fix-curl.patch View File

@ -1,29 +0,0 @@
From 4fa98f0b0b493ebbef616404dbc03ba5fe811997 Mon Sep 17 00:00:00 2001
From: userwithuid <userwithuid@gmail.com>
Date: Sun, 27 May 2018 12:47:15 -0700
Subject: [PATCH] fix logic for setting the curl ca bundle file
we do not want to delete the system default by setting this to NULL...
---
libtransmission/web.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/libtransmission/web.c b/libtransmission/web.c
index db349760b..997a151b5 100644
--- a/libtransmission/web.c
+++ b/libtransmission/web.c
@@ -191,7 +191,10 @@ createEasy (tr_session * s, struct tr_web * web, struct tr_web_task * task)
#endif
if (web->curl_ssl_verify)
{
- curl_easy_setopt (e, CURLOPT_CAINFO, web->curl_ca_bundle);
+ if (web->curl_ca_bundle != NULL)
+ {
+ curl_easy_setopt (e, CURLOPT_CAINFO, web->curl_ca_bundle);
+ }
}
else
{
--
2.17.0

+ 0
- 25
net/transmission/patches/070-uClibc-ng-since-1.0.18-has-sys-quota.h-synced-with-G.patch View File

@ -1,25 +0,0 @@
From e24f7c6653ec385c8af7eb6499d924994e78e42d Mon Sep 17 00:00:00 2001
From: Waldemar Brodkorb <wbx@uclibc-ng.org>
Date: Wed, 19 Oct 2016 19:33:35 +0200
Subject: [PATCH] uClibc-ng since 1.0.18 has sys/quota.h synced with GNU libc
---
libtransmission/platform-quota.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libtransmission/platform-quota.c b/libtransmission/platform-quota.c
index e7d1f6d4f..bb1f9d9b9 100644
--- a/libtransmission/platform-quota.c
+++ b/libtransmission/platform-quota.c
@@ -285,7 +285,7 @@ getquota (const char * device)
spaceused = (int64_t) dq.dqb_curblocks >> 1;
#elif defined(__APPLE__)
spaceused = (int64_t) dq.dqb_curbytes;
-#elif defined(__UCLIBC__)
+#elif defined (__UCLIBC__) && !TR_UCLIBC_CHECK_VERSION (1, 0, 18)
spaceused = (int64_t) btodb(dq.dqb_curblocks);
#elif defined(__sun) || (defined(_LINUX_QUOTA_VERSION) && _LINUX_QUOTA_VERSION < 2)
spaceused = (int64_t) dq.dqb_curblocks >> 1;
--
2.17.1

+ 5
- 5
net/transmission/patches/080-disable-webseeding.patch View File

@ -1,11 +1,11 @@
--- a/libtransmission/webseed.c
+++ b/libtransmission/webseed.c
@@ -516,8 +516,6 @@ webseed_timer_func (evutil_socket_t foo UNUSED, short bar UNUSED, void * vw)
if (w->retry_tickcount)
++w->retry_tickcount;
@@ -510,8 +510,6 @@ static void webseed_timer_func(evutil_socket_t foo UNUSED, short bar UNUSED, voi
++w->retry_tickcount;
}
- on_idle (w);
- on_idle(w);
-
tr_timerAddMsec (w->timer, TR_IDLE_TIMER_MSEC);
tr_timerAddMsec(w->timer, TR_IDLE_TIMER_MSEC);
}

Loading…
Cancel
Save