Browse Source

nginx: fix leftover code that flood the logs

Stop flooding logs as stated at https://dev.openwrt.org/ticket/17317.

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
lilik-openwrt-22.03
Thomas Heil 10 years ago
parent
commit
92bd6b1f49
2 changed files with 1 additions and 12 deletions
  1. +1
    -1
      net/nginx/Makefile
  2. +0
    -11
      net/nginx/patches/400-nginx-1.4.x_proxy_protocol_patch_v2.patch

+ 1
- 1
net/nginx/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.4.7
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nginx.org/download/


+ 0
- 11
net/nginx/patches/400-nginx-1.4.x_proxy_protocol_patch_v2.patch View File

@ -882,17 +882,6 @@ Index: nginx-1.4.7/src/http/ngx_http_request.c
#if (NGX_HTTP_SSL)
@@ -1291,6 +1368,10 @@ ngx_http_read_request_header(ngx_http_re
c = r->connection;
rev = c->read;
+fprintf(stderr, "DEBUG: pos: %p, last: %p, start: %p, end: %p\n",
+ r->header_in->pos, r->header_in->last, r->header_in->start,
+ r->header_in->end);
+
n = r->header_in->last - r->header_in->pos;
if (n > 0) {
Index: nginx-1.4.7/src/http/ngx_http_upstream.c
===================================================================
--- nginx-1.4.7.orig/src/http/ngx_http_upstream.c


Loading…
Cancel
Save