Sysrepo release 0.7.4lilik-openwrt-22.03
@ -1,47 +0,0 @@ | |||
Index: libyang-0.14.53-2698bd6484526facbf82b1263810b938b82a2f23/src/extensions.c | |||
=================================================================== | |||
--- libyang-0.14.53-2698bd6484526facbf82b1263810b938b82a2f23.orig/src/extensions.c | |||
+++ libyang-0.14.53-2698bd6484526facbf82b1263810b938b82a2f23/src/extensions.c | |||
@@ -123,11 +123,14 @@ lyext_load_plugins(void) | |||
/* and construct the filepath */ | |||
asprintf(&str, "%s/%s", pluginsdir, file->d_name); | |||
- | |||
- /* load the plugin - first, try if it is already loaded... */ | |||
- dlhandler = dlopen(str, RTLD_NOW | RTLD_NOLOAD); | |||
- dlerror(); /* Clear any existing error */ | |||
- if (dlhandler) { | |||
+ /* load the plugin */ | |||
+ dlhandler = dlopen(str, RTLD_NOW); | |||
+ if (!dlhandler) { | |||
+ LOGERR(LY_ESYS, "Loading \"%s\" as a plugin failed (%s).", str, dlerror()); | |||
+ free(str); | |||
+ continue; | |||
+ } | |||
+ if (ly_set_contains(&dlhandlers, dlhandler) != -1) { | |||
/* the plugin is already loaded */ | |||
LOGVRB("Extension plugin \"%s\" already loaded.", str); | |||
free(str); | |||
@@ -137,14 +140,6 @@ lyext_load_plugins(void) | |||
continue; | |||
} | |||
- /* ... and if not, load it */ | |||
- dlhandler = dlopen(str, RTLD_NOW); | |||
- if (!dlhandler) { | |||
- LOGERR(LY_ESYS, "Loading \"%s\" as an extension plugin failed (%s).", str, dlerror()); | |||
- free(str); | |||
- continue; | |||
- } | |||
- LOGVRB("Extension plugin \"%s\" successfully loaded.", str); | |||
free(str); | |||
dlerror(); /* Clear any existing error */ | |||
@@ -156,6 +151,7 @@ lyext_load_plugins(void) | |||
dlclose(dlhandler); | |||
continue; | |||
} | |||
+ LOGVRB("Plugin \"%s\" successfully loaded.", str) | |||
for(u = 0; plugin[u].name; u++) { | |||
/* check extension implementations for collisions */ |
@ -1,40 +0,0 @@ | |||
Index: netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/keystored/CMakeLists.txt | |||
=================================================================== | |||
--- netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee.orig/keystored/CMakeLists.txt | |||
+++ netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/keystored/CMakeLists.txt | |||
@@ -105,6 +105,7 @@ endif() | |||
install(DIRECTORY DESTINATION ${KEYSTORED_KEYS_DIR} | |||
DIRECTORY_PERMISSIONS OWNER_WRITE OWNER_READ OWNER_EXECUTE) | |||
+if(FALSE) | |||
# install all the required modules and enable features | |||
install(CODE " | |||
execute_process(COMMAND ${SYSREPOCTL_EXECUTABLE} -l RESULT_VARIABLE RET OUTPUT_VARIABLE INSTALLED_MODULES ERROR_VARIABLE OUT) | |||
@@ -154,6 +155,7 @@ install(CODE " | |||
message(FATAL_ERROR \" Command sysrepocfg import failed:\\n \${OUT}\") | |||
endif() | |||
endif()") | |||
+endif() | |||
# plugins should be installed into sysrepo plugins dir | |||
install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR}) | |||
Index: netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/server/CMakeLists.txt | |||
=================================================================== | |||
--- netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee.orig/server/CMakeLists.txt | |||
+++ netopeer2-c204b59f9c2bb7e63eb907f33c44adbf208295ee/server/CMakeLists.txt | |||
@@ -147,6 +147,7 @@ include_directories(${SYSREPO_INCLUDE_DI | |||
# install binary | |||
install(TARGETS netopeer2-server DESTINATION ${CMAKE_INSTALL_BINDIR}) | |||
+if(FALSE) | |||
# only for configuration | |||
if (ENABLE_CONFIGURATION) | |||
# find sysrepoctl | |||
@@ -239,6 +240,7 @@ if (ENABLE_CONFIGURATION) | |||
endif()") | |||
endif() | |||
+endif() | |||
# clean cmake cache | |||
add_custom_target(cleancache |